problems after attempting to install nvidia propietary drivers

Hi, i installed the nvidia propietary drivers and then entered sudo nvidia-xconfig. When i restarted i could not get to the graphical interface. I have tryed init 5 and that has done nothing. I found people having a similiar issue with ati cards. I tried their solution
Replacing the ati drivers with the nvidia ones.

Still nothing happened. I also tried booting into recovery desktop mode and get stuck at " ok ] Reached target Graphical interface."
nothing happens after this.

I am running opensuse 13.1 gnome and my computer is an msi gs70
any help is greatly appreciated.

You don’t have to (and shouldn’t) run nvidia-xconfig, the nvidia driver is used automatically if it is installed and working.
Apparently it is not working though.
By running nvidia-xconfig, you forced Xorg to unconditionally use the nvidia driver. As it cannot be loaded (for whatever reason), Xorg fails to start.
To get back to a graphical system, remove the /etc/X11/xorg.conf that nvidia-xconfig created.

I am running opensuse 13.1 gnome and my computer is an msi gs70.

It’s bad that you use GNOME. GNOME will not work as long as the nvidia driver is installed, not even in “Recovery Mode”.
So uninstall the driver again, you can use YaST for that, that works in text mode as well.

Or use “zypper se nvidia” to find out which nvidia packages you installed, and remove them with “zypper rm package1 package2 …”.

Then please post your repo list, and what exact graphics card model you have:

zypper lr -d
/sbin/lspci | egrep -i "vga|3d"

If this is a laptop with hybrid graphics (intel+nvidia), you cannot use the normal nvidia driver, you’d need Bumblebee in that case.

Any chance that this is a Intel+NVIDIA GPU system. It is hard to tell from the specs but just about every Intel processor I have seen lately has a GPU. If so it is an Optimus system and you need to either turn off one of the GPUs or use bumblebee. Note that none of the descriptions say Optimus but then the ones I found are not great technical descriptions. You may want to confirm or not that this is a Optimums based system before following the below instructions

Note that before applying bumblebee you need to totally remove the NVIDIA driver you installed you need to use the special NVIDIA-bumblebee driver NOT the regular one.

To remove the NVIDIA driver you will need to boot to a terminal and run YAst from the command line. Assuming a EFI install you need to press ‘e’ at the boot screen find the line starting linux go to the real end (it wraps) ie press end key enter a space and a 3 continue the boot with F10. Log into the terminal as root. then type yast go to software management and search for NVIDIA

Assuming you installed GO3 flavor of NVIDIA you will see 5 packages with the NVIDIA name remove these. That should bring you back to day one. Now follow exactly the instructions on the bumblebee page

I removed the file /etc/X11/xorg.conf. I was unable to run zypper se nvidia, kept on getting an error saying curl so instead i did it through yast. Now when i boot up it gets to the stage right before where i would normally login but the picture looks like it is in the wrong spot and the end that is cut off has rolled over to the left hand side. after waiting for a bit this turns into a black screen where my mouse is visible and movableI tried using recovery mode and i get to the same place as before.

Have you really removed all nvidia packages?

rpm -qa | grep nvidia

Open /etc/sysconfig/kernel in a text editor (you should have vim and nano installed, which both work in text mode) and make sure it says NO_KMS_IN_INITRD=“no”, then run “sudo /sbin/mkinitrd”.
The nvidia driver packages set this to “yes” and don’t revert it on uninstallation, which might give problems with KMS drivers like intel.
Although this shouldn’t affect recovery mode. IIUYC, you only get to text mode when running recovery mode?

If that doesn’t help, try setting “xdm” as DISPLAYMANAGER in /etc/sysconfig/displaymanager, and “icewm” as DEFAULT_WM in /etc/sysconfig/windowmanager. Do you get a graphical system then?

So i got it working again, the nvidia drivers were uninstalled. Just did as you said and set it to no and ran sudo /sbin/mkinitrd
after this i installed the bumblebee drivers and everthing was working great. I then tried to update and after restarting i get to my login screen but if i wait for a few seconds or try to log8n it will hang for a couple seconds then go to a screen where the final message is panic occured, switching back to text console. From here i cant do anything and after a minute or so it restarts.
Thanks again and sorry for all the questions.

Did the update pull the NVIDIA drivers back in?

Did you install the NVIDIA-bumblebee package???

Yes, this could happen.

You should uninstall the drivers again if they are installed. And remove the nvidia repo, or the driver will get installed again.

They arent installed. Prior to updating I removed the nvidia repository. Now im not getting to my login screen even and i cant get to the command line. It goes directly to “Rebooting in 90 seconds…” prior to this i had ran the /sbin/mkinitrd

Didn’t you say /sbin/mkinitrd made your system working again, and then you installed bumblebee and everything work great?
And some updates caused the current problem?

Does it help when you try to boot to recovery mode?
Does it help when you add “1” to the boot options to boot to rescue mode?

Do you have another kernel in the boot menu which might work? (in “Advanced Options”)

It did get it working again but after attempting to update to 13.2 and having problems, i checked if the nvidia drivers were present and i ran /sbin/mkinitrd, this causes my computer to restart after 90 seconds.

Recovery mode does the same thing.

How would i add 1 to the boot options to boot rescue mode?

I tried all the other kernels, none worked.

You never mentioned anything about updating to 13.2 either.

How exactly did you do that “update”?

How would i add 1 to the boot options to boot rescue mode?

Press ‘e’ at the boot menu to edit the currently selected entry, search for the line starting with “linux”, and append ‘1’ to the end. Then press ‘F10’ to boot.

Sorry, forgot to clarify that the update was to 13.2

I added the one and it had no effect.

I followed this guide to update.

So you replaced all 13.1 repos with the 13.2 ones and ran “zypper dup”?

I only ever saw that “Rebooting in 90 seconds” issue on a broken Live-USB. But AFAIK this implies that the root filesystem or even the initrd cannot be mounted.

Could you maybe post a screenshot? Maybe there’s something on the screen that gives a hint.

Do you get to a minimal text system when adding “rd.break” to the boot options (instead of ‘1’)?
If not, you definitely need some CD/DVD/USB medium to boot from to possibly fix that.

But it’s probably easier to boot from a 13.2 installation medium at this point and select “Update”, to update again to 13.2, i.e. re-install 13.2 offline.