Problems accessing network

I have just upgraded from v11.4 to v12.2 and I cannot get access to my network. I have changed the workgroup to my group but am unable to see other computers on the network. It also means I can’t access a printer on another machine which I need to print.

I am trying to use Yast to configure but I’m not sure what to change. I would like to manually set the IP address for the computer but if I try to do this I lose connection to the Internet - it is currently set to ‘Dynamic address’. I have tried to add the details for a manual IP and set the name servers to 192.168.1.1 (router) but this stops internet access.

Any advice appreciated.

Mike

On 2012-12-02 14:26, mikejd wrote:
>
> I have just upgraded from v11.4 to v12.2 and I cannot get access to my
> network. I have changed the workgroup to my group but am unable to see
> other computers on the network. It also means I can’t access a printer
> on another machine which I need to print.
>
> I am trying to use Yast to configure but I’m not sure what to change. I
> would like to manually set the IP address for the computer but if I try
> to do this I lose connection to the Internet - it is currently set to
> ‘Dynamic address’. I have tried to add the details for a manual IP and
> set the name servers to 192.168.1.1 (router) but this stops internet
> access.

Your description is incompatible. If you have access to Internet, then
you do have network. What you have is problems with samba.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 12/02/2012 08:03 AM, Carlos E. R. wrote:
> On 2012-12-02 14:26, mikejd wrote:
>>
>> I have just upgraded from v11.4 to v12.2 and I cannot get access to my
>> network. I have changed the workgroup to my group but am unable to see
>> other computers on the network. It also means I can’t access a printer
>> on another machine which I need to print.
>>
>> I am trying to use Yast to configure but I’m not sure what to change. I
>> would like to manually set the IP address for the computer but if I try
>> to do this I lose connection to the Internet - it is currently set to
>> ‘Dynamic address’. I have tried to add the details for a manual IP and
>> set the name servers to 192.168.1.1 (router) but this stops internet
>> access.
>
> Your description is incompatible. If you have access to Internet, then
> you do have network. What you have is problems with samba.

I agree with Carlos. Your networking is fine as long as all the configuration
parameters are set correctly, which is what happens when you set a dynamic
address. With manual IP, you are probably not setting the default route.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Also agreed, although while useful information (that the gateway is
likely being omitted when manually configuring, as that’s a common
oversight) it doesn’t help with the original issue.

@OP: How are you trying to access the other machines on your network,
exactly? On my 12.2 system I can access windows machines by doing
something like the following as long as they are sharing stuff (I assume
they are windows boxes and not Linux or something better like that using
Samba as Larry Finger and Carlos pointed out):

\192.168.1.2\c$

Put in your own SMB server’s IP address (the server is the thing sharing
files with you… even if it’s a workstation it’s running the SMB
service if it ever shares files via SMB as you claim it does). The ‘c$’
portion accesses an evil automatic share windows puts in place for the
entire c-drive; you’ll likely need to use your windows credentials to
get access since otherwise your setup is completely insecure.

If you are using Linux for the SMB service, or if you have another share
defined on any platform, just change the last part to the appropriate
share name

\server.ip.goes.here\shareNameHere

Oh, and put that string into Dolphin (for KDE users) or something
equivalent on the Gnome side of things.

Good luck.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
Comment: Using GnuPG with undefined - http://www.enigmail.net/

iQIcBAEBAgAGBQJQu4/cAAoJEF+XTK08PnB5G/kQALY22E6/AygCM9+QoposrKQJ
SgF1x0rfJvGcu87xcw3Wmt5W0/fNVmGhNMLIv+nw84VGVVKjhy791/uOVdQ6ItxB
s6Tw+nTK5UvjwcIsM4PiO/cTvRZ25DBkGLEP4ep8S8WMjVzgZ4PORprcbqav0wfa
RbxENHj9M7Xce524nrdKk88XMUP8MmUzGJZvfchvgmKxrnZ4WFqI7EX1+W5Tzq23
i5SJ3HYZoDF1yHJj6uTqclJReBia6NYowc5PFCxGynKvQgLmdRHcBxdtH+pzheML
Vh8gvohXvgi1UB2+vBLD9fWYvnsKLww0qr+hdBC4aN2O3f1MaBnj5Wvu2YmAs2q/
Gte7xoi24H+uvxsqVHDaQlnwpMzfe11MSru53CG0b9hLRaCe0goRp9qojNRm45oo
pHjdES7aoiBd99i7F3Wx+dgNYhvnejCGM7dTYVORfFcJE6noTf4C8jsKUVMcDhUo
pJ0D4fHrFUD2aLLUPa6l+2aJDBKzE+pyFcbqRp/tAoRr8kWbsjAuUZKB3I+dOX+H
vA3hNPP2aw3dPf1R0SKPUuiH4uKBeCakqklcLPMiK+yd0YCZzUN6zsiUJAdR7cgM
DrGgqsaGOPLw7poCmGpVATo4fTZaLR/beO1kOfwAQQfSmKzrUwSmHVVLdFhXM3MR
Nw5enYDZZ72aMoH0jXW3
=iHkK
-----END PGP SIGNATURE-----