Problème with compiz

Hi everybody.

It’s the first time I use openSUSE, after installing it, the first thing I did is upgrade to kde 4.2, after that i wanted to install compiz fusion… but err… I can’t find “Fusion-Icon” for launch compiz…

I’m on OpenSUSE 11.1, and when I try to install the 1 click installation for compiz, fusion icon don’t install.

Anybody know how to use compiz without fusion icon ? Because i’m totaly stuck… and I realy want to use compiz.


It must be already installed. Can you open the Menu, go to “Configure Desktop” and see?

Well… i don’t want to INSTALL it but USE it. I just don’t know how to use it without fusion-icon. And i can’t find “Configure desktop” on the menu K because i’ve already delete useless thing on the menu.

If you’re sure it has installed correctly, then from within the KDE session, open a console and type

compiz --replace

That should start it.

If i do that, there’s no windows decoration… and if i close konsole. It’s look like compiz is closed too.

I have unistall compiz. Someone can help me how to reinstall it and use it correctly ?

Thank a lot.

I think this will do nicely for a step by step.

Compiz hell ? Need help - openSUSE Forums

If you have any problems post back here.

Good Luck,


Sorry, to use compiz as the main Window Manager you should click on the application launcher (k-icon or green openSUSE lizard) then click applications then Configure Desktop (Personal Settings). Then under Personal choose Default Applications. Select Window Manager and then choose Use a different window manager. Choose compiz (not compiz custom).

That should get compiz-fusion up and running after you’ve set it up properly as shown to from the link on my previous post.

Good Luck,


Oh, gee. It’s finally works. Thanks ! But it look like there’s some problems with the installed packages… But I think I can do the other thing by myself.

Thank a looooooooot.

No problem, also if alt+f2 or the print screen button don’t work, that’s also covered in that first link I posted. It seems to work without any configuration for some and not for others.

Take Care,