Probleme mit NVIDIA - Zweitkarte

Moin,

ich versuche leider immer noch die zweite NVIDIA-Karte zum Laufen zu bringen.

Habe sowohl diese Anleitung versucht: https://en.opensuse.org/SDB:NVIDIA_Bumblebee als auch die Standard-Installation über YAST.

Leider immer mit diesem Ergebnis:

~> primusrun glxspheres
primus: fatal: Bumblebee daemon reported: error: [XORG] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

Jemand eine Idee? Vielen Dank schon mal.

As per the bumblebee post install notifications…

INFO: Please ensure that users using bublebee/video card are in following group(s):*
INFO: gpasswd -a <USER> bumblebee*
INFO: If going to use nvidia binary driver:**
INFO: gpasswd -a <USER> video
INFO: Also ensure the nouveau module is blacklisted (even if you plan to use it):****
INFO: echo “blacklist nouveau” >> /etc/modprobe.d/50-blacklist.conf**
*INFO: mkinitrd

***You might need to add your user to the video group as highlighted but not mentioned in the guide.

nVidia Bumblebee steam issue - Applications - openSUSE Forums**

Unfortunately this is not the problem… get still the same error message.
It’s a little bit strange because under Leap 42.X the second card ran without any problems.

https://forums.opensuse.org/showthread.php/522828-optirun-fails-failed-to-set-DRM-interface-version-1-4-Permission-denied

https://wiki.archlinux.org/index.php/bumblebee#.2Fdev.2Fdri.2Fcard0:_failed_to_set_DRM_interface_version_1.4:_Permission_denied

So, ich hab’s für’s Erste aufgegeben…
Mit dem Nouveau-Treiber funktioniert’s nicht und mit dem NVIDIA-Treiber läuft zumindest “optirun” (“primusrun” nicht); das System kriegt damit allerdings Probleme und ich zerschieße mir X… Das hat mir heute zwei Neuinstallationen beschert.
Da ich auf die zweite Karte nicht angewiesen bin, vertage ich das Ganze wohl besser auf Leap 15.1…

https://en.opensuse.org/SDB:NVIDIA_Bumblebee:

Don’t use primusrun anymore. Optirun is everything you need.

In the old times optirun was a wrapper script for setting up VirtualGL bridge. Then primus library appeared with it’s own primusrun wrapper script. Now optirun is a program integrated with bumblebee daemon and supports both VirtualGL and primus bridges.

But unfortunately, with the NOUVEAU-driver, it would be still the same problem:

~> primusrun glxspheres
primus: fatal: Bumblebee daemon reported: error: [XORG] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

The only driver I get to run under Leap 15.0 is the NVIDIA-one, but that crashes my X for some reason… so I’ll wait until 15.1 for a next try.