Problematic audio on Linux

Hello folks!

I am having an issue for a long time with pacmd sinks. Firstly I should say that I’ve tried several distros and the only ones I don’t have problems are Ubuntu 20.04, Debian Testing and Windows OS. The thing i wonder is why only Debian based ones do work properly compared to OpenSUSE, Fedora, Manjaro, Arch

Now let me explain the problem. I will try to explain but it is kind of hard for me I’ll try my best. The audio button on Gnome have 3 icons for me. Headphones, speaker, speaker(over amplified). It constantly switches between the speaker and headphones without plugging any headphones. Furthermore, I get no voice on headphones mode(I get voice if i really plugged a headphone) and usually it is quantized voice I get. Too disturbing… I have tried a lot of stuff related to pulseaudio and ALSA. What I got is i can solve it for a little time by using

pacmd set-sink-port alsa_output.pci-0000_00_09.2.analog-stereo analog-output-speaker

During the process to get this little command I searched lots and lots of forums and had sleepless nights. I was amazed that it worked out! However, it does not and I should repeat the command continuously. After using Debian and Ubuntu I forgot the issue but I want to return back to openSUSE!

You should be able to add the desired configuration to /etc/pulse/ for permanent effect…

set-sink-port alsa_output.pci-0000_00_09.2.analog-stereo analog-output-speaker