Problem with YAST

I just installed openSUSE 11 x64 off of DVD today, and worked through most of my issues and have a stable and fast system. My one remaining issue is that some things that I try to install with YAST it tries to install the .i586 file instead of the x86_64 file which results in:

uvcvideo-kmp-default-r171_2.6.25.5_1.1-3.4.i586 requires kernel (default:vmlinux) = e61690aa8c2e0b5e, but this requirement cannot be provided
uninstallable providers: kernel-default-[repo-oss]

Following actions will be done:
architecture change of kernel-default- to kernel-default-

I’m puzzled by this and don’t understand what is going wrong here, I took a look and the x86_64 version does exist in the repository. Any ideas what I’m doing wrong?

I don’t know, it works fine for me. Have you tried just selecting it to install, and then before hitting accept, manually change the version to x86_64 on the versions tab?

Although you may have a more systemic problem than that. Does it happen with any other software, or just that one package?

Surely you should be looking for an x86_64 version of this package?


I simply picked the package, it was YAST that selected the i586 version… That was kind of the point of the whole post, as I would have expected the correct version to be selected automatically.