problem with wireless

Hey guys,

  I installed suse 11.1 and tried to make wireless work..I followed the instructions given in 

Getting Your Wireless to Work - openSUSE Forums

I found the entry named Wireless Lan (Kernel drivers:ssb).
Now I referred to
b43 - Linux Wireless

and used
sudo /usr/sbin/install_bcm43xx_firmware

and downloaded compat drivers from
http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-2.6.tar.bz2

When I do make it dnt show me any errors but when I used make install its saying

"

Now run:

make unload

And then load the wireless module you need. If unsure reboot.

"

I typed sudo make unload then its saying

Unloading ssb…
FATAL: Module ssb is in use.

So i tried rebooting my system…Still no use :frowning:

Now again I went to yast-> hardware->hardware info to check wireless lan…Now thers no entry at all at the position where i found for first time!!!(But ders something wireless lancard entry in Network card entry)

Now the output of firmware (dmesg | grep firmware is

firmware: requesting b43/ucode5.fw
firmware: requesting b43/pcm5.fw
firmware: requesting b43/b0g0initvals5.fw
firmware: requesting b43/b0g0bsinitvals5.fw
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)

What to do??Is broadcam and compat same…Did I do anything wrong??plz help me…

Eeeesh!! you’re trying to use 2 different drivers for the same thing.Use one or the other,preferrably b43 as it appears to be working

Andy

p.s.this should be in the wireless section

rajeshksv37 wrote:
>
> What to do??Is broadcam and compat same…Did I do anything wrong??plz
> help me…

As Andy said, your device should be working. To answer your question, there is a
special developmental kernel tree called wireless-testing. It contains the
latest version of the mainline kernel (2.6.29-rc7 at the moment) plus the latest
wireless code. These drivers are the ones that will be in kernel 2.6.30.
Compat-wireless is the wireless code from wireless-testing reformatted to be
built in a standalone configuration. For your device, there is not likely to be
any difference, but there are a number of cards that work only with
wireless-testing.

Larry

Tks andy and lary…I gt ur point tht I tried 2 use two drivers for same thing…Now finally nthng is working…What should I do now…Should I uninstall both and install one of them??I donno how 2 uinstall either :frowning: Can u briefly temme wt 2 do?

Your dump of the dmesg output showed that one of the drivers was loading
firmware. At that point, you only need to configure the interface, either using
ifup or NetworkManager. I suggest the latter. Find the network applet in the
right-hand corner of the screen (lower for KDE, upper for Gnome), right click on
it and select “New Connection”. Follow the screens, fill in the data, and it
should work.