Problem with Wireless using a Dell laptop with Opensuse 11.3 installed

I have a Dell laptop Studio 1735 bought more or less two years ago. I decided to install Opensuse 11.3 and when the installation process finished the wireless card was not working. As a newbie in Linux I have started to make my own research in internet and I discovered that the cards with Broadcom chipset give some troubles.

So I started to gather all the information about my wireless card and I tried to solve the issue by myself, but unfortunately I did have no success. I report below the info I got with Yast and the line command tool.

  1. Yast=> Hardware => Hardware Information

Wireless 1510 Wireless-N WLAN Mini-Card
Kernel Driver:ssb

And the rest of the info log

34: PCI c00.0: 0280 Network controller
[Created at pci.318]
Unique ID: zb5c.gyef+lfqPY1
Parent ID: qTvu.1SGvPCdkja9
SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:0c:00.0
SysFS BusID: 0000:0c:00.0
Hardware Class: network
Model: “Dell Wireless 1510 Wireless-N WLAN Mini-Card”
Vendor: pci 0x14e4 “Broadcom”
Device: pci 0x432b “BCM4322 802.11a/b/g/n Wireless LAN Controller”
SubVendor: pci 0x1028 “Dell”
SubDevice: pci 0x000d “Wireless 1510 Wireless-N WLAN Mini-Card”
Revision: 0x01
Driver: “b43-pci-bridge”
Driver Modules: “ssb”
Memory Range: 0xf6cfc000-0xf6cfffff (rw,non-prefetchable)
IRQ: 17 (2 events)
Module Alias: “pci:v000014E4d0000432Bsv00001028sd0000000Dbc02sc80i00”
Driver Info #0:
Driver Status: ssb is active
Driver Activation Cmd: “modprobe ssb”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #21 (PCI bridge)

  1. /sbin/lspci

09:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe (rev 10)
0c:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)

  1. /sbin/lspci -nnv | grep 14e4

09:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe [14e4:1698] (rev 10)
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)

  1. sudo /usr/sbin/iwlist scan

lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

pan0 Interface doesn’t support scanning.

  1. **/usr/sbin/iwconfig **

lo no wireless extensions.

eth0 no wireless extensions.

pan0 no wireless extensions.

  1. dmesg | grep b43

    6.709978] b43-pci-bridge 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    6.709993] b43-pci-bridge 0000:0c:00.0: setting latency timer to 64
    6.815352] b43-phy0: Broadcom 4322 WLAN found (core revision 16)
    6.830292] b43-phy0 ERROR: FOUND UNSUPPORTED PHY (Analog 8, Type 4, Revision 4)
    6.831035] b43: probe of ssb0:0 failed with error -95

  2. dmesg | grep Broadcom

    1.555156] usb 3-1: Manufacturer: Broadcom
    6.815352] b43-phy0: Broadcom 4322 WLAN found (core revision 16)
    6.831048] Broadcom 43xx driver loaded Features: PMLS, Firmware-ID: FW13 ]

What I have done so far was to download the firmware from the following address

I download it in my USB memory stick and copied it in my home directory. After I did the following:

tar xjf broadcom-wl-
b43-fwcutter -w /lib/firmware broadcom-wl-
sudo /sbin/modprobe -rv b43
sudo /sbin/modprobe -v b43

but unfortunately after rebooting everything was like before: the wireless is still not working. I tried to use NetworkConnection but the Wireless tab is not even available.

It seems that it is not a firmware issue.

Please, can anyone help me ?

All 802.11n Broadcom devices need to use the Broadcom wl driver. Search this Forum for instructions on how to install it.

The b43 developers are working on getting such devices to work, but that code is not ready.

Please post the result of:

uname -a


zypper lr -d

And we can help you install the ‘wl’ driver

I have the same card, the Dell Wireless 1510 card requires the braodcom STA driver. You can find it here (it comes with instructions)

As you requested I report below the result of the commands.

  1. uname -a

Linux 2.6.34-12-desktop #1 SMP PREEMPT 2010-06-29 02:39:08 +0200 x86_64 x86_64 x86_64 GNU/Linux

  1. zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes | Yes | 99 | NONE | [ |
2 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
3 | repo-debug | openSUSE-11.3-Debug | No | Yes | 99 | NONE | [ |
5 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | NONE | [ |
6 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | [|

Please bear in mind that I do not have access to internet when I am using Opensuse.
Please tell me if you have enough information to understand which driver I need to install (I was reading the other posts and it seems that they change from case to case).

My apologies for the bad format!!!](](]( |

Thank you.

Please download and install the following

To install them you may have to force the first one because they are dependant on each other: You need to open the terminal in the location you have the files, become su - and do the following

rpm -ivh --force


rpm -ivh

when done reboot.
If you have trouble get back

Thank you very much for your help!!! It worked perfectly!!!

Strangely, once I created a folder where I placed the two files, I had to reverse the two commands. First I did

**rpm -ivh

and after

rpm -ivh --force

But anyway it worked

Now I have a little question for you.
Since I am a newbie in Linux (but everybody has been one initially) I would like to know which is the best path for learning this OS better (apart reading the manuals).
I am asking this (maybe for you trivial question) because after my own research in Internet, I saw too many informations and not up to date. So I do not know which are the best books or sites for improving my knowledge.

Again thank you for your support so far

Take it slowly.
If in the past you have used windows. Then know this: Linux is NOT windows.

Probably the most important things to learn is Software Installation: This is done with Yast>Software>Software Management
The software available to install in there is dependant on your ‘Repositories’. Don’t add repositories at a whim. In fact, all you should really need beyond those installed by default, is the Packman repository.
If you were to follow this guide: Multi-media and Restricted Format Installation Guide
You will probably have most of what you need.

In my signature you will see ‘My Guides’ My Guides
You will find quite useful info in there. But never hesitate to ask for advice.

You should never login as root. If you don’t know what I mean, that’s probably good. But you can do any ‘root’ work as user with su -
But don’t worry too much about it for now.

This might be good to read: Concepts - openSUSE

@caf4926 : u hv helped me a lot and thanks for the links to those tutorials they will help me a lot :slight_smile:

No problem. You are welcome.

Sorry to open this back up but…
I have installed the broadcom-wl rpm’s from the packman repo:

rpm -qa | grep broadcom

uname -a
Linux jkennedy-17dell #1 SMP PREEMPT 2010-10-25 08:40:12 +0200 x86_64 x86_64 x86_64 GNU/Linux

With this card:
03:00.0 Network controller: Broadcom Corporation BCM43224 802.11a/b/g/n (rev 01)

I can now see eth1 (only 1 wired card) and I can configure wireless in NetworkManager but I get no connection and iwlist scan says interface does not support scanning.

What am I missing?

PS - Forgot the following from YaST -> Hardware -> Hardware Information

Network Interface │
│ ├+─Loopback Network Interface │
│ ├+─Ethernet Network Interface │
│ └┬─Ethernet Network Interface │
│ ├──Bus: None │
│ ├──Class (spec): Ethernet │
│ ├──Class: Network interface │
│ ├──Device Name: eth1 │
│ ├┬─Device Names │
│ │└──eth1 │
│ ├──Driver: wl │
│ ├──Hwcfg Bus: none │
│ ├──Kernel Driver: wl │
│ ├──Model: Ethernet network interface │
│ ├──Old Unique Key: ujoW.ndpeucax6V1 │
│ ├──Parent Unique ID: JNkJ.p6aAv2YUcqD │
│ ├┬─Resources │
│ │├┬─HW Address │
│ ││└──addr: c4:17:fe:8d:08:d4 │
│ │└┬─link │
│ │ └──state: Yes │
│ ├──Sysfs ID: /class/net/eth1 │
│ └──Unique Key: L2Ua.ndpeucax6V1

You only need the two packages shown above in red.
Unless you know you have those other kernel types installed and use them. But I somehow doubt it.

Now post the result of this (just the wireless part please)

/sbin/lspci/ -nnk

Just a typo error I think but there is no forward slash after /sbin/lspci. Correct command is:

/sbin/lspci -nnk


/sbin/lspci -nnk

Thanks ah7013

So I am no expert at Wireless, but I just purchased a $50 wireless N router at the house and it does work with my work laptop. One thing I ran into trying to get NetworkManager to work had to do with mixed versions I had loaded. After I got them all from the same repository, it started working. I would ask that you run the following Terminal command and post your output:

rpm --query --all --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} -> %{VENDOR}
' '*NetworkManager*'

When I run this, here is what I get:

NetworkManager-0.8-8.2.1-x86_64 -> openSUSE
NetworkManager-vpnc-kde4-0.9.svn1057339-4.1-x86_64 -> openSUSE
NetworkManager-pptp-gnome-0.8-3.1-x86_64 -> openSUSE
NetworkManager-kde4-0.9.svn1057339-4.1-x86_64 -> openSUSE
NetworkManager-pptp-kde4-0.9.svn1057339-4.1-x86_64 -> openSUSE
NetworkManager-glib-0.8-8.2.1-x86_64 -> openSUSE
NetworkManager-vpnc-gnome-0.8-3.1-x86_64 -> openSUSE
NetworkManager-pptp-0.8-3.1-x86_64 -> openSUSE
NetworkManager-kde4-libs-0.9.svn1057339-4.1-x86_64 -> openSUSE
NetworkManager-openvpn-gnome-0.8-3.1-x86_64 -> openSUSE
NetworkManager-openvpn-kde4-0.9.svn1057339-4.1-x86_64 -> openSUSE
NetworkManager-vpnc-0.8-3.1-x86_64 -> openSUSE
NetworkManager-gnome-0.8-5.1-x86_64 -> openSUSE
NetworkManager-openvpn-0.8-3.1-x86_64 -> openSUSE

If you anyone else has Wireless working and use NetworkManager, you might post what you have loaded as well.

Thank You,

At your insistence

NetworkManager-kde4-libs-0.9.svn1184295-5.2-x86_64 -> obs://
NetworkManager-vpnc-kde4-0.9.svn1184295-5.2-x86_64 -> obs://
NetworkManager-pptp-gnome-0.8-3.1-x86_64 -> openSUSE
NetworkManager-kde4-libs-lang-0.9.svn1184295-5.2-noarch -> obs://
NetworkManager-pptp-kde4-0.9.svn1184295-5.2-x86_64 -> obs://
NetworkManager-vpnc-gnome-0.8-3.1-x86_64 -> openSUSE
NetworkManager-kde4-0.9.svn1184295-5.2-x86_64 -> obs://
NetworkManager-pptp-0.8-3.1-x86_64 -> openSUSE
NetworkManager-openvpn-gnome-0.8-3.1-x86_64 -> openSUSE
NetworkManager-openvpn-kde4-0.9.svn1184295-5.2-x86_64 -> obs://
NetworkManager-vpnc-0.8-3.1-x86_64 -> openSUSE
NetworkManager-glib-0.8-8.2.1-x86_64 -> openSUSE
NetworkManager-0.8-8.2.1-x86_64 -> openSUSE
NetworkManager-gnome-0.8-5.1-x86_64 -> openSUSE
NetworkManager-openvpn-0.8-3.1-x86_64 -> openSUSE

Never had an issue yet

So I see that I have 14 files while you have 15 I think. I keep looking but I could not determine which one was extra over mine, perhaps it is just too late here. Also, you have stuff loaded from OBS, while I don’t have that repository added. In my case, the files I had that were mixed were from the KDE 4.4 repository which were newer than in openSUSE and that seemed to cause me a problem. Beyond that, it is hard to determine what the two listings mean when put side by side. Thanks for posting your files there caf4926.

Thank You,

No problem :slight_smile:

NetworkManager-kde4-libs-lang-0.9.svn1184295-5.2-noarch -> obs://

might be the one