Problem with Windows 7 Dual-Boot

My problem is that I have installed openSUSE 11.2 on a laptop with Windows 7 already installed. Yast resized my Windows partitions, which seemed to upset Windows as I had to go to my Windows Recovery Disc to restore it. When Windows was restored it did something so that GRUB no longer appeared. So I did a system recovery for openSUSE 11.2 which then removed Windows 7 from GRUB! Now I’m trying to restore Windows 7 and configure GRUB so that Windows and openSUSE will stop fight for boot supremacy and play nice with each other.

Here are my Yast2 Boot Loader settings:

Section Management Settings
SUSE LINUX (type)image (/dev/sda6, root=dev/disk/by-id/ata-ST9320320AS_5SX4PRAS-part6)
Failsafe – SUSE LINUX (type)image (/dev/sda6, root=dev/disk/by-id/ata-ST9320320AS_5SX4PRAS-part6)

Boot Loader Installation Settings
Boot Loader: GRUB
Boot Loader Location: Boot from Extended Partition
Disk Order: /dev/disk/by-id/ata-ST9320320AS_5SX4PRAS

Here is output from cfdisk:

Name Flags Part Type FS Type

         Primary      Free Space      

sda1 Primary NTFS
sda5 NC Logical Linux swap/Solaris
sda6 NC Logical Linux ext3
sda7 Logical Linux ext3
Logical Free Space
sda2 Primary NTFS
Primary Free Space

I tried writing this code to /boot/grub/menu.lst:

title Windows
rootnoverify (hd0,0)
chainloader (hd0,0)+1

I received this error message:

**rootnoverify (hd0,0)
chainloader (hd0,0)+1

Error 1: Filename must be either an absolute pathname or blocklist

Press any key to continue…

If anyone has any constructive suggestions I would really appreciate it!

Windows has a system partition that should be hd0,0 so I am thinking that your chain loader should point to hd0,1. Give that a try and see if it works.

Thank you for the suggestion. Unfortunately writing:

chainloader (hd0,1)+1

did not work. I get the same error message.

What about:

**title Windows
rootnoverify (hd0,1)
chainloader +1



Thanks for the “magic words”!!


A follow-up to my previous “success” …

I was successful at restoring Windows 7 access with the coed please_try_again suggested. However, as before, Windows 7 seems to have kicked off (“booted” off?) GRUB from my bootup sequence. For when I restarted my laptop only Windows 7 appeared. 8-(

That’s because the Grub bootloader is installed in the extended partition. It should be installed in MBR too.

I haven’t used SuSe in a few years and just recently got a laptop with windows7. When I installed Windows I created just a 50gb partition of unallocated space with every intention on installing suse on it just to get reaquainted with it. When I go to run my installation disc of 11.2, the only option I have is to reformat basically everything just to install it. Any help would be greatly appreciated. I would really like to get this running so I can finally get back to using linux more regularly.

Create your partitions with Parted Magic before installing Linux.
In Linux setup, select the option ‘create partition setup’, choose one by one your partitions, select mountpoints and format. Don’t touch your Window partitions.
I explained the method with more details in that other post:
Need Help with Partitioning for dual boot - Page 2 - openSUSE Forums

Better install Grub in MBR (this is not the default).

I am also facing same issue but in my case openSUSE is not able to recover the MBR and crashes everytime, i have a thread also for the same here few threads above this. Waiting for some responses …