Problem with webcam


I have a Genius Webcam (it’s an old one, don’t know the exact model, but it’s usb). Recently I updated to OpenSuse 11.2. It wasn’t working in 11.0 either, but now I noticed that the green led on the cam is on when I plug it in (which didn’t happen before).

Anyway, I tried to use it with Cheese, but it says there’s no camera…

Tried to use lsusb but it just freezes :frowning:

So… Here’s a part of my hwinfo:

usb_device.vendor = ‘OmniVision Technologies, Inc.’
usb_device.product = ‘OV511+ Webcam’
usb_device.device_revision_bcd = 256 (0x100)
info.product = ‘OV511+ Webcam’
usb_device.num_ports = 0 (0x0)
usb_device.linux.device_number = 3 (0x3)
usb_device.max_power = 500 (0x1f4)
usb_device.speed = 12.0000
usb_device.version = 1.00000
info.vendor = ‘OmniVision Technologies, Inc.’
usb_device.can_wake_up = false
usb_device.bus_number = 2 (0x2)
usb_device.is_self_powered = false

Any suggestion? Thanks!

If you have not done so already, please look at the wiki: HCL/Web Cameras - openSUSE

I have a hard time reading this

usb_device.product = 'OV511+ Webcam'
usb_device.device_revision_bcd = 256 (0x100)
info.product = 'OV511+ Webcam'

Instead please provide the device and vendor id of your webcam by typing with your webcam plugged:



Thanks for your answer. I’ll check the wiki page (I believe I have done so, but still…).

I tried to use the command lsusb, but it just freezes on me… I don’t get any result at all… Any other way to do it? (I thought hwinfo would help…)

IMHO,if lsusb freezes on you, then your PC has bigger problems than just getting your Webcam to work.

Well, actually, I forgot to specify that this problem only happens when I have the cam plugged… every other usb device works just fine.

In fact, I’m not sure the cam is not working, since the led is on while the camera is plugged in… I just couldn’t get Cheese to recognize it…