Problem with vlc

I am having this problem with vlc.

easgs@linux-4ns1:~> vlc
VLC media player 2.2.4 Weatherwax (revision 2.2.4)
[00000000010e80b8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[00000000011ff608] core interface error: corrupt module: /usr/lib64/vlc/plugins/gui/
[00007fcc20030c28] core generic error: corrupt module: /usr/lib64/vlc/plugins/gui/
[00000000011ff608] skins2 interface error: no suitable dialogs provider found (hint: compile the qt4 plugin, and make sure it is loaded properly)
[00000000011ff608] skins2 interface error: cannot instantiate qt4 dialogs provider
[00000000011ff608] [cli] lua interface: Listening on host "*console".
VLC media player 2.2.4 Weatherwax
Command Line Interface initialized. Type `help' for help.
> ^C[00000000011ff608] [cli] lua interface error: Error loading script /usr/lib64/vlc/lua/intf/cli.luac: lua/intf/modules/host.lua:279: Interrupted.

looks like you haven’t updated Qt5, vlc builds with the current Qt 5.5.1 libraries from the update repo I think you have the old Qt 5.3 from the oss/dvd repo,
just do an update

sudo zypper up

you could also post your repo list so we can see if you didn’t accidentally add an incompatible repo (mixing tw or 13.x and leap repo’s will give the same error)
post the output of

zypper lr -d

Well, actually there’s Qt 5.5.0 in the main repo and DVD. 5.3(.2) was shipped in 13.2 already… :wink:

But yes, that’s the likely reason for the problem.
Or some mixture of incompatible Qt5 packages, from different repos.

I mixed up the kde 5 with the Qt 5 versions :frowning:
but that does look like a Qt mixmatch error

linux-4ns1:/home/easgs # zypper lr -d
#  | Alias                     | Nombre                                  | Habilitado | Comprobación GPG | Actualizar | Prioridad | Tipo   | URI                                                                                    | Servicio
 1 |          | Packman Repository                      | Si         | (r ) Si          | Si         |   99      | rpm-md |                          |         
 2 | openSUSE-42.1-0           | openSUSE-42.1-0                         | Si         | (r ) Si          | No         |   99      | yast2  | cd:///?devices=/dev/disk/by-id/ata-VMware_Virtual_IDE_CDROM_Drive_10000000000000000001 |         
 3 |   | Libdvdcss Repository                    | Si         | (r ) Si          | Si         |   99      | rpm-md |                                     |         
 4 | repo-debug                | openSUSE-Leap-42.1-Debug                | No         | ----             | Si         |   99      | NONE   |                    |         
 5 | repo-debug-non-oss        | openSUSE-Leap-42.1-Debug-Non-Oss        | No         | ----             | Si         |   99      | NONE   |                |         
 6 | repo-debug-update         | openSUSE-Leap-42.1-Update-Debug         | No         | ----             | Si         |   99      | NONE   |                                |         
 7 | repo-debug-update-non-oss | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No         | ----             | Si         |   99      | NONE   |                           |         
 8 | repo-non-oss              | openSUSE-Leap-42.1-Non-Oss              | No         | ----             | Si         |   99      | NONE   |                      |         
 9 | repo-oss                  | openSUSE-Leap-42.1-Oss                  | Si         | (r ) Si          | Si         |   99      | yast2  |                          |         
10 | repo-source               | openSUSE-Leap-42.1-Source               | No         | ----             | Si         |   99      | NONE   |                   |         
11 | repo-update               | openSUSE-Leap-42.1-Update               | Si         | (r ) Si          | Si         |   99      | rpm-md |                                     |         
12 | repo-update-non-oss       | openSUSE-Leap-42.1-Update-Non-Oss       | No         | ----             | Si         |   99      | rpm-md |                                 |         
linux-4ns1:/home/easgs # 

linux-4ns1:/home/easgs # zypper up
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...

Las siguientes 33 actualizaciones NO serán instaladas:
  amarok amarok-lang dolphin4 fdupes gstreamer-0_10 gstreamer-0_10-lang gstreamer-0_10-plugin-esd
  gstreamer-0_10-plugins-base gstreamer-0_10-plugins-base-lang gstreamer-0_10-plugins-good
  gstreamer-0_10-plugins-good-lang k3b k3b-lang ksnapshot libavcodec56 libavformat56 libavutil54
  libgstapp-0_10-0 libgstinterfaces-0_10-0 libgstreamer-0_10-0 libkdcraw23 libkexiv2-11 libkface3 libkgeomap2
  libkipi11 libksane0 libmjpegutils-2_0-0 libquicktime0 libsox3 libswresample1 mjpegtools sox xembed-sni-proxy..........

.............shared-mime-info shared-mime-info-lang shim snapper
  snapper-zypp-plugin snmp-mibs solid-imports solid-tools star strace subversion sudo suse-module-tools sweeper
  sysconfig sysconfig-netconfig syslinux systemd systemd-32bit systemd-bash-completion systemd-logger
  systemd-presets-branding-openSUSE systemd-sysvinit systemsettings5 systemsettings5-lang tar tar-lang tcpdump
  tigervnc timezone translation-update translation-update-es typelib-1_0-GdkPixbuf-2_0 typelib-1_0-Gtk-2_0
  typelib-1_0-Gtk-3_0 typelib-1_0-Polkit-1_0 ucode-amd udev util-linux util-linux-lang util-linux-systemd w3m
  webkit2gtk-4_0-injected-bundles wicked wicked-service xdg-utils xdm xfsprogs xorg-x11-server xorg-x11-Xvnc
  xscreensaver-data xscreensaver-data-extra yast2 yast2-bootloader yast2-firewall yast2-inetd
  yast2-installation yast2-mail yast2-network yast2-ntp-client yast2-packager yast2-samba-server
  yast2-services-manager yast2-storage yast2-update yast2-users zypper zypper-aptitude zypper-log

Los siguientes 27 patrones van a ser actualizados:
  base devel_basis enhanced_base enhanced_base_opt fonts fonts_opt games imaging imaging_opt kde kde_games
  kde_imaging kde_internet kde_multimedia kde_plasma kde_utilities kde_utilities_opt kde_yast multimedia
  multimedia_opt non_oss non_oss_opt sw_management sw_management_kde x11 x11_opt yast2_basis

**852 paquetes a actualizar, 250 nuevos, 11 a quitar.**
Overall download size: **1,20 GiB**. Already cached: 0 B. Después de la operación, se utilizarán **1,6 GiB**
¿Desea continuar? [s/n/? mostrar todas las opciones] (s): 

852 paquetes a actualizar, 250 nuevos, 11 a quitar.
Overall download size: 1,20 GiB. Already cached: 0 B. Después de la operación, se utilizarán 1,6 GiB

I think that is too much just to make vlc work, is there a way to just update the only necessary packages?, I have had very bad experiences making updates.


opensuse uses delta rpm’s for the update repo, so while the amount of data modified is more then 1 Gib the amount of data downloaded will be 10-20% of that or 100-200 MB or maybe even less, you really should keep your OS updated LEAP is almost a year old there have been a lot of security and stability updates since it came out.
read up about delta rpm’s here

Delta RPM packages contain the difference between an old and a new version of an RPM package. Applying a delta RPM onto an old RPM results in a completely new RPM. It is not necessary to have a copy of the old RPM because a delta RPM can also work with an installed RPM. The delta RPM packages are even smaller in size than patch RPMs, which is an advantage when transferring update packages over the Internet. The drawback is that update operations with delta RPMs involved consume considerably more CPU cycles than plain or patch RPMs.

that being said I can not tell you how much will be downloaded but rest assured it will be a lot less then 1.4G

Just to know, is there or are there especific files that need to be updated to make vlc work?

I think I will be testing other video players instead, I have a lot of data (more than 400 gb in multimedia files) in the home partition of this pc and if I damage the OS I have no external back up to make a reinstall, hope this is fixed in the 42.2 release, I like Vlc.


to get multimedia working you need to do a full vendor change with the packman repo, you do not have to use vlc as there are other players (kaffeine that comes with kde 5 is nice so is smplayer)
to get multimedia working you need to do

zypper dup --from 1

this is a must as openSUSE does not provide patented codecs so even if you do an update your multimedia (including vlc) will not work if you have not done a vendor change to packman!
you can use Yast for the vendor change but the zypper way is simpler :slight_smile:

It likely will suffice to just update the Qt5 packages (i.e. libQt5* and libqt5*).
I’d strongly recommend to install all updates though.

I think I will be testing other video players instead, I have a lot of data (more than 400 gb in multimedia files) in the home partition of this pc and if I damage the OS I have no external back up to make a reinstall, hope this is fixed in the 42.2 release, I like Vlc.

The home partition won’t be touched by updates, and the updates should not do any damage (that’s one reason why the policy is to only provide bugfix and security updates, not new feature versions, as official updates normally).

If you use btrfs (the default for the system partition since openSUSE 13.2), you’d also be able to easily revert to the old state in the unlikely case there are problems.
You can even boot a previous snapshot by selecting this in the boot menu.

Ok, but even then it is not correct… :wink:

Leap 42.1 shipped with Plasma 5.4.
5.3(.2) is the version in openSUSE 13.2 (+Updates).

this is way off topic but I was testing the 64bit Foxit reader for Linux, it came with a strange windows like installer and it came with (installed) Qt 5.3,
I ran it as an ordinary user so all the files ended up in my $HOME, that’s where the Qt 5.3 came from, from Foxit reader for Linux, surprisingly it is a rather good application way more capable then the abandoned Acrobat reader (which is 32bit only), it should support interactive pdf’s too (it might be the only native Linux application that does that) but I haven’t seen an interactive pdf in ages.
if someone wants to try it here’s a link to the current version

ps never ever run the run installer as root as you might break your system!!!
ps ps they use to have an rpm but they removed it, I have no idea why maybe avoiding double rpm and deb packaging?

For the moment Kaffeine will be doing the job for playing videos and music, now even amarok doesn’t work nor smplayer, mpv, Videos/totem it seems they got broken in my testing to make vlc work, in fact kaffeine is the only media player that is working now.

I think a OS reinstall will solve this but the problem is that I don’t have an external media to back up the files for the moment to make a clean install.

the main functions of this computer are: playing videos and music, converting video files to different format, converting music files to different formats, as long as I can do that it’s ok.

show zypper lr -d

he hasn’t done an update and still uses the original 42.1 system libraries (there wore a lot of security and bug fixes in Qt5 and kf5)
amarok is a Qt app too and the packman version (which will be pulled if you did a vendor change like I told you) is build against the current Qt libraries!
although I think amarok is Qt4
if you did

zypper dup --from 1

amarok should run fine but you need an update, 10 months (I think 42.1 came out in nowember 2015) is forever in the Linux world and as I said openSUSE uses delta rpm’s for the update repo and while the amount of modified data will be 1.2 GB the download should be bellow 200 MB

Amarok/totem sounds like a gstreamer problem.
(Amarok is a KDE4/Qt4 application, totem a GTK/GNOME one, both do not use Qt5)

Do a full switch to Packman then (as already instructed), and install gstreamer-fluendo-mp3, gstreamer-plugins-bad-orig-addons, gstreamer-plugins-ugly-orig-addons, and gstreamer-plugins-libav (if they are not installed already).

If that still doesn’t help, remove the gstreamer plugin cache, ~/.cache/gstreamer-1.0/.

If mpv doesn’t work, smplayer will not work either as it is just a frontend.
A full switch to Packman should fix that too.

If not, you’ll have to describe what you mean exactly with “doesn’t work”.

lol!Yo there!, another sugestion: I dont see the vlc repo showed in

So why dont give a try,

In the other hand you could try to install mplayer (not smplayer :stuck_out_tongue: I dunno if this is the same or its a frontend)

you should not get things from both the packman and vlc repos. they may not mix well. Best to use only packman unless you full understand the possible ramification. :open_mouth:

^this the vlc repo does not comtaom a working copy of gstreamer, do a dup with packman and pull all multimedia from there, Firefox and Amarok and a lot of other 3rd party apps need a working copy of gstreamer for multimedia support, also the vlc repo has a custom build of ffmpeg, mixing 3 versions of ffmpeg (the oss, packman’s and vlc’s) might get you into dependency hell

you really need to do a full vendor change with packman
but if you want to try vlc, try the beta 3.0 I think that one is build with Qt4 and should run on your setup

zypper in vlc-beta