Problem with virtualbox


I installed virtualbox version 3.1.4 by adding the virtualbox repository but when trying to run a VM machine I get:

kernel driver not installed (rc =- 1908) and reinstall the kernel module to /etc/init.d/vboxdrv setup as root.

When I run this command:

/etc/init.d/vboxdrv setup

Recompiling VirtualBox kernel modules, NOT. It has-been packaged. done

But still the same problem.

You need the ‘virtualbox-kmp’ package for your kernel.

You don’t say which version you installed the OSE or the PUEL. There are repos for both, one maintained by openSUSE volunteers, the other by Sun/Oracle. Knurpht assumes you have the OSE version. If you really wanted the PUEL version then remove the OSE first before installing PUEL.

If with PUEL you then get a message saying no C compiler or no kernel sources, then have a look at previous threads in the forum about what packages you need to install to run the setup.

I have the virtualbox-ose

I automatically installed the virtualbox-ose-kmp-default although there are others like it as:


that are not installed.

You should install the official version of sun?

Ok, someone else with experience with OSE should help you then. I use PUEL. Both versions are official and should work, except that PUEL has some features that OSE doesn’t (OSE is totally open source, while PUEL has some proprietary components). You can carry on with OSE until you need PUEL. You can read a description of the differences in features at

You need to install the one that is the same as you kernel.

uname -r

will tell you the version running

I always just grab the generic Linux version from Sun. Then being sure that I have the gcc compiler and the kernel-source for my running kernel installed I run the installer and it compiles the program for me.

I installed the version of sun and matter resolved.