Problem with VirtualBox kernel module compilation - Request help

[Re-posted here as per advise in Applications Forum]

Hello All,

I am running latest Tumbleweed.

I have kernel and C/C++ build environment through respective PATTERNS. Also,complete kernel sources.

I have installed Virtualbox 5.1.14(opensuse-152 version) from their website. I am trying to compile the modules with ‘/sbin/vboxconfig’ as root.

P.S.** I know that is two year old version and I can install the latest TW-version which I have uninstalled as it is producing inexplicable freezes on winxp guest on serial port. Before uninstalling official VB versions, I have tried VB 6.1.2 (over current 6.0.4) from unofficial build too.Both produce the same result. But 5.1.4 had been working for me on another machine till recently. Serial port use is part of my work ]

The compilation itself generates no error till the end,but the module does not get built. I have looked up their scripts,but do not see anything amiss.I blame it on my inexpert eye****.

I am attaching the install log here****. **Any help will be much appreciated. Thanks in advance.