Problem with the File Includes Foreign Character

Hi everyone. On my system, I am not able to open such a file with foreign characters(in my case, Turkish characters). As you see in the figure, Libre Office cannot run it. I also have same issue on Mendeley Desktop application. Due to the Turkish characters, Mendeley thinks that file is broken.

How can I handle with this issues?

Thank you.](

/run/media implies this is removable drive. What filesystem is used on this drive? What character set is used for file names on it?

Not a regular user of Mendeley,
IIRC it’s a web browser based collaboration tool.

This will likely mean that it depends on how you’re trying to view the document…
If within a web browser (like a web page) then you’ll likely have to talk to the Mendeley folks, maybe there is a plugin. In any case, I’d be surprised if this is the case, guessing that UTF-8 support should be standard in all web browsers today and ought to be able to display Turkish characters.

On the other hand, collaboration tools often pass a file to a “Viewer” program, in which case you have to look at the capabilities of the app that is trying to open the file. So for example if it’s a latex app, we have Latex character sets for many languages in the openSUSE repos.

If you have many text viewer apps on your machine, then you can save the file to disk and instead of using whatever default viewer is configured on your system, rt-click on the file and “Open with…” your choice of apps in the drop-down or browse to another app.


I am afraid it is not related with my removable drive because same issue happend when i try to open a file which is on desktop.](

What I tried was not open with a Mendeley, I just tried to open with Libre Office Writer. This error message arise due to opening with Libre Office.

I thought it is due to encoding issues because when I began to use a newly formatted OpenSUSE, I couldnt reach my file and folder which are named with Turkish character. After installing Turkish support, I got rid of that issue. However I am now struggling with this problem.

My advice is focusing on encoding issues.

As I described, you can try opening with any other text writers already installed on your machine on the chance they might have what is required.
If that doesn’t work, then you may have to ask the person who created the file whether the text is utf-8 (unicode), and if that is the case then you need to use a text editor that supports utf-8. A quick Internet search suggests that Libre Writer has problems so you may have to use something else (Ocular?)