Problem with static ip address ? / Suse 12.1 - 64bit

Problem with static ip address ?
I have installed Suse 12.1 64 bit.
The network is configured with a DHCP so receive an address from my local router. Network seems to work fine in this config – i.e Firefox works.
When I change to configure a static address, using Yast > Network Card Setup with following parameters:
Statically assign IP : say Mask: Host Name: come up automatically with And under Routing eneter the local router default i.e
This seems to be accepted. i.e with ifconfig see new address / However no actual working internet connection can be obtained ? i.e ping to pc from other pc works, showing new (static) address.

I have seen various loose remarks, that possibly some issue exists with Ver 12.1.

Can anyone please kindly advise how to set a static IP address ? - in a simple step 1,2, ,n fashion please ?

Comments / Remarks are kindly appreciated

Hash: SHA1

I don’t see where you specified DNS servers; without them pinging by
anything other than IP address will work because an IP address is not
resolved from a DNS name of some sort. Those settings are also under
the Hostname/DNS.

Good luck.
Version: GnuPG v2.0.18 (GNU/Linux)
Comment: Using GnuPG with Mozilla -


ab mentions one good point… You didn’t specify exactly whether you ping’d by name or IP address, if by name then DNS (and all other name resolution systems including the client machine resolver cache) would be an issue.

Also, if you’re using Network Manager, you might try configuring your static address that way (frankly I haven’t tried it personally but see it as an option now).

You might also try pinging both directions to verify whether the problem is specific to the change you just made or a more basic networking issue.


Simple solution: Go to the DNS entries and enter and as DNS’s. These are Google’s, they’re fast and reliable.

Thanks for your comment. Yes, I have just entered so DNS entries, for example I have been reading about, Well, now it seems to work ! – Obviously, I am not a network engineer.
I have also just looked under my Linksys router status and copied the results into the Yast Network Settings which also work as alternatives to the google indentfiers.
OK – So I have learnt something (1,5 days spent on this issue) and hopefully this information may help others.

Many Thanks

Note that this solution (configuring remote DNS eg Google’s) means that although you can resolve Public Internet names, you won’t be able to access any other machines/network resources in your network by name (if it’s not important to you, fine).