Problem with sr0 solved in openSUSE 11.1

I posted this on a much older thread, but because it was of interest to so many people, I thought it might also go here. The problem was that in openSUSE11.1, the optical drive designated as sr0 in /dev was not available to software such as VLC or Xine in the user account, but was available in root…a permissions problem.

I have finally addressed and solved the problem of sr0 in openSUSE 11.1 and it turns out to be the solution suggested by an earlier contributor, but I give the specific details for those who are not really familiar with some of the panels, and I certainly was not before I started. Here are the steps starting with YaST:

YaST -> Security and Users -> User and Group Management

This will open a window in which you as the user are highlighted, now at the bottom select Edit, then the Details tab and from the list that is then revealed, check “disk” and exit/save all the changes.

Once that is done, sr0 is instantly available to VLC and Xine in the user account. You will find that the players simply use their default settings of /dev/sr0 no matter what dvd title is placed in the drive. What is curious however is that if you look at the same location in openSUSE 11.0, “disk” is NOT checked. So in 11.0, something else has been done to make /dev/sr0 just work happily. However,my workaround above solves the problem in 11.1 and I would imagine it would also work for 11.2. Whether or not this workaround exposes the user to less security I am unable to say, however I do know it works well for what I want to do.

I haven’t tried it yet, but I have a feeling this will also help in certain aspects of loading software into Crossover Office where you have to insert an earlier “proof of ownership” copy before a Win-based item such as Photoshop will install. I ran into severe problems with this in 11.1…I am hoping that is now fixed.

Thanks all for the advice and help in the earlier forum :slight_smile: