Problem with sound - internal speakers cease to work on openSUSE 12.2

I have a problem with sound from internal speakers on openSUSE 12.2. I use Toshiba Satellite L750-1N3 laptop, and everything worked OK till a couple of weeks ago (I suppose, till some update). I’ve had no problems with this laptop and openSUSE (clean install of 12.1, then upgrade to 12.2) for more than a year.

I’ll try to describe the problem: After booting the system, the sound works. Then, after a short time playing sound (mp3, youtube video, whatever in whichever application), the sound disappears. When I plug in the headphones or external speakers, they work normally. The only way to reactivate the sound from internal speakers is either to reboot or to play with configuration of the sound card (delete, then configure again, change some settings etc.) in Yast. There is no regular sequence which reactivates the sound (except rebooting). I tried to change the options of the snd-hda-intel module (model, enable_msi, probe_mask, position_fix, power_save) as found in various forums but none of them worked. The multimedia and all necessary applications (as far as I know) are installed and configured correctly.

I found a lot of descriptions of this problem with internal speakers and snd-hda-intel through years, but all the solutions were just for a particular case, not general, and none of them were for my laptop.

Any idea how to try to resolve the problem?

Thanks!

Additional info: I’ve tested sound with Ubuntu 10.04 live distro, and internal speakers work fine. Obviously, the problem was caused by updates in last two weeks. Does anybody knows what parts of the system were updated recently, or where to find this info?

Thanks!

Just and observation. Sometimes when i reduce volume to very low levels in media players the mixer takes volume level to zero. Then i have to open the the mixer applet in panel and increase the volume again in applications tab.

samimk, I answered that question on a thread you started on the same subject : https://forums.opensuse.org/english/get-technical-help-here/multimedia/483211-no-sound-all-opensuse-12-2-a.html

As a moderator, I have a mind to merge these two threads, as else time is being wasted of those attempting to help.

OK, I intended to move to this thread, since everything looks like the hardware+module configuration problem.

Thanks!