Problem with snapshot 20190621 and rtl8821ce-kmp-default

When updating wlan was gone even with rtl8821ce-kmp-default installed. modprobe 8821ce reports not found. Any idea?

Does it still work with the previous kernel?

Note: I don’t think there was a new kernel with 20190621, but you might have skipped an earlier update and picked up a new kernel anyway.

I had paused for some months and installed kernel-default 5.1.7-1.2 despite some warnings regarding rtl8821ce-kmp-default. When I updated to http://download.opensuse.org/repositories/home:/Sauerland/Kernel_stable_standard/x86_64/rtl8821ce-kmp-default-git20190530_k5.1.14_1.gf291042-2.19.x86_64.rpm the older kernel would not work either. However I found http://download.opensuse.org/repositories/Kernel:/stable/standard/x86_64/kernel-default-5.1.14-1.1.gf291042.x86_64.rpm , installed and got a working wlan. :slight_smile:

When you run a Tumbleweed Kernel, use this Repo:
https://download.opensuse.org/repositories/home:/Sauerland:/hardware/openSUSE_Tumbleweed/

The other Repo is for use of kernel:stable…

Reverted both kernel and wireless driver to version 5.1.7 and now get a working connection too.

Did you try also the Bluetooth-kmp?
Does it work with Tumbleweed?

I got the following by default:

notebook:~ # zypper se --installed-only --repo home_Sauerland_Tumbleweed '*'
Loading repository data...
Reading installed packages...

S  | Name                     | Summary                                                      | Type   
---+--------------------------+--------------------------------------------------------------+--------
i  | broadcom-wl              | Wireless driver for Broadcom 43xx series of Chips            | package
i  | broadcom-wl-kmp-default  | Wireless driver for Broadcom 43xx series of Chips            | package
i  | r8168-blacklist-r8169    | To favour r8168 blacklist the r8169 device driver            | package
i  | r8168-kmp-default        | To favour r8168 blacklist the r8169 device driver            | package
i+ | rtl8821ce-kmp-default    | Wlan-Driver for Realtek RTL8821CE 802.11ac WLAN Adapter      | package
i  | rtl8821ce_bt-kmp-default | Bluetooth-Driver for Realtek RTL8821CE 802.11ac WLAN Adapter | package
notebook:~ # 

The Bluetooth applet shows up in the system tray. But currently I have no appliance to test with.

The system is back to business as usual. Duped to 5.1.10-1 without issues. But need to wait for rtl8821ce-kmp-default to get updated too.

The system is back to business as usual. Duped to 5.1.10-1 without issues. But need to wait for rtl8821ce-kmp-default to get updated too.

Thats because I have not the priority as other OBS-user…

I have trigerred a rebuild, it should be there in a short time:

Duped again and booted into 5.1.10-1-default. Everything is fine now. :cool: