Problem with Siemens Gigaset 108 USB Wireless adapter

Hey everyone,

I have an urgent and rather strange problem that I am hoping you can help me with. First a bit of background, so you may understand why this is important to me.

I am in the process of switching my parents over to Linux. In the past, they’ve always run Windows, but recently their machine became slower and slower. Upon investigation, it was infested with spyware. They don’t know how it got on there, but they’re not very computer literate. All they do is use email, surf the web a bit and use Internet banking. Ideal candidates to move to Linux, I’d think.

So I offered to reinstall their machine, this time with openSUSE 11. I got all their data off and installed Linux. It works very well, except for one thing. The only thing I can’t get to work is their wireless adapter.
The adapter is a Siemens Gigaset 108 USB adapter. It uses an Atheros 5523 chipset and it also gets shown as a USB device in Yast2 > Hardware info. It’s not recognized as a network adapter though.

So far, I have tried two approaches to get this to work:

  1. Ndiswrapper

  2. Madwifi

  3. Ndiswrapper
    Using Ndiswrapper, I can get the adapter to work…partially. I downloaded the driver from the distributor’s website (KPN, for the Dutch readers). I installed the driver with ndiswrapper and it is then recognized after loading ndiswrapper via modprobe. So far so good.
    Starting KNetworkmanager, I can then scan for available networks and connect…but only to open access points. Of course, I don’t want to open my parent’s wireless to the entire world…
    Furthermore, before shutting down the PC, the adapter needs to be unplugged, otherwise the PC hangs at boot the next time with the adapter plugged in. Turning on the machine, modprobing ndiswrapper and then plugging in the adapter is not an acceptable procedure.

  4. Madwifi.
    According to the Madwifi wiki, the Atheros 5523 chipset should be supported. At least, it is shown here as supported. So I installed Madwifi from the repository listed on this page: Atheros madwifi - openSUSE.

However, following that procedure, I can not get the card recognized at all. I installed the necessary stuff (madwifi and the madwifi kernel module).
At the end, I am supposed to modprobe ath_pci, which I do. But that doesn’t help me much, since the adapter is not a pci device, it’s USB. So…how can I use the device with Madwifi? Or is that impossible?

Can someone please help me? I have been struggling with this adapter for 2 days and I have come to the point where I don’t know what else to try…

I’m still struggling with a 5523 chipset in another manufacturer’s usb adapter. I hope you get this resolved. I’ll learn from you.

Madwifi does not work with usb. It was not designed to. They may find a way in the future, but for now it is specifically designed without usb support.

I have a message about firmware when I do lsusb. In another thread, I was advised to look at dmesg to see which firmware it is looking for. On another forum (an old posting) someone said that ar5523.sys was the firmware.

I haven’t tried any of this yet, since I am still trying to get through all the new posts on this forum. :wink:

If I find an answer before you do, I’ll post back.


Yes, I also understood from the Madwifi crowd that they don’t support USB adapters now. Which leaves ndiswrapper, which sort of works, sort of doesn’t.

I’ve now invested 4 days of trial and error, googling and irc to find a working solution for this problem. It seems there is none.

For people who need a USB wireless adapter, I was recommended the atheros-n series usb with ar9170 chipset, which does work with Linux.


You may want to look at this site. It looks like they have native drivers/firmware for this NIC.
ar9170 - Linux Wireless