Problem with shutdown, openSUSE 13.1


I have problem with shutdown/reboot of openSUSE 13.1 with my Moxa DA-820. When I give command for reboot/shutdown in any way, from terminal, trough GUI… it starts shutdown procedure, but in one moment it hangs with a black screen, and it never powers off. I’ve tried with acpi=force in grub2, tried to turn off Wake on lan,… but nothing solved my problem.

I’ve tried to install openSUSE 13.2, and with it, I don’t have any problem, but I would like to solve a problem with 13.1 also.

Any idea?

You say you have this with 13.1 .Now 13.2 is already out for some time.

Do you mean that you installed 13.1 recently and thus have the problem from the beginning?

Do you mean you have installed 13.1 some time ago (when it was the newest version) and that you have the problem from the beginning since a long time (and then why didn’t you post earlier)?

Or do you mean you installed 13.1 earlier, but that the problem only shows up recently (and them is that after an update or what)?

13.2 I have downloaded from openSUSE website, and 13.1 I’ve got from a friend. 13.1 is LiveCD created with SUSE Studio. This 13.1 is working without problem at several other computers/servers. I’ve tried 13.1 first, and as I had problem with it, I’ve downloaded 13.2.

My conclusion: you have the problem with a 13.1 Live CD created by someone on SUSE Studio.

Would have been better when you had mentioned that in your first post. Everybody of course assumes that you use the standard distribution when you do not say different.

Yes, your conclusion is right. Sorry, I haven’t mentioned that at the first post. I have talked with they guy who created it, and he said, that there are no significant changes comparing to standard distribution. I’ll try with standard distribution also.

Just to clarify, every once in a while, my 13.1 system does the same thing. I can’t repeat it on demand, hence I never asked anyone about it. I simply wait for a while and then press power button or reset button, which ever is appropriate. Can’t add anything useful except to confirm OPs complaint.

[edit] I just remembered I turned off a setting in my BIOS that was allowing the system to keep the memory alive during a warm boot. I guess to provide a quicker boot for those poor slobs running Windows >:). Haven’t rebooted enought to tell if it made a difference. AMI BIOS on ASUS board.

Video/driver? It is often the video driver that causes that.

Thanks for all your help on this forum. Can you expand on this advice? I am another user running 13.1 with similar intermitent shut-down issues to the OP, so interested in this discussion. In my case running nVidia 340.76 driver. Hard re-boot always causes fear but so far I have had a graceful recovery each time.

You did not say which card.

Thank-you. In my case the device is nVidia GF114 [GeForce GTX 560].

On this machine [Intel i7-2600 CPU @ 3.40GHz] running openSUSE 13.1 KDE 4.14.6 shutdown (from Launcher Menu) fails in 10% of cases, usually after this OS has been up for 48 hours or more. Shutdown problems are reduced, but not eliminated, when I log out and initiate shutdown from the login menu screen. I have not seen this issue when running a test installation of openSUSE 13.2 on the same machine, but that OS is rarely up for more than a few hours.

Mine is Intel® HD Graphics 4000.

I’ve downloaded 13.1 (live KDE) from openSUSE website, and I haven’t noticed any problem with it. I’m trying to find out what is causing problem with distribution I have, but now without success :frowning: I’ve tried it at several other computers, and there, it is working without any problem.