Problem with screen resolution!

Hi, I’m fairly new to linux and I just installed OpenSUSE 11.0 and I really like it, but I have an annoying problem with my screen resolution.
First, I installed the newest Ati proprietary driver, which you can download from AMD’s website, when the driver was installed I opened a terminal, typed ‘su’, ‘aticonfig --initial -f’ and restarted my pc.
When my pc was restarted, I opened Ati Catalyst Control Center, and moved the Display Area slider from 1280x1024 to 1600x1200, ok everything works perfect, the screen resolution is now 1600x1200 until I log out or restart my pc:confused:. My graphical card is: Ati Radeon 9800XL (128MB VRAM)

I already tried several things but it won’t work.:confused::mad:

PS: Sorry if my English is bad (I’m from Belgium)

Have you tried to configure screen resolution with yast?

Thank you for such a quick reply!:wink:
When I try configuring my screen resolution via YaST I get the following error: ‘Cannot Deactivate All Displays - At least one display must be active’:eek:, and if I click on the OK button it displays like normal the configuration window, where I can configure the screen settings, but again: the resolution reverts back after a restart or re-login.
I also tried configuring my screen using the gnome applet and results in the same (except the error):confused:.

The gnome-applet, imo, is really useless, I delete it without even take care to it.

Here is a sax2 screenshiot:
What you have to do is not only change the resolution, but to change the monitor (click on the “change…” button beside the “monitor” line).

Then, carefully find a monitor with the same resolution and refresh rate than your monitor (generally you can find them under vesa section or lcd section).

You can also edit xorg.conf, but it’s a little bit more troublesome.

And, do you have a nvidia card?


I have an Nvidia 7300LE and a Samsung 225BW monitor and even though I edit xorg.conf I STILL can’t get it to go to 1680x1050!!!

The only choices I EVER see in “Resolution” are 800x600 and 1024x768.

I did NOT have this problem with 10.3.