problem with Samba Server

i followed the sticky (along with other various walkthroughts for
opensuse 11.1) on how to set up the samba share for windows network but
when i go to my laptop (which runs windows) i can’t access anything

help appreciated

Dave


Kotomine

Kotomine’s Profile: http://forums.opensuse.org/member.php?userid=19398
View this thread: http://forums.opensuse.org/showthread.php?t=404325

Kotomine wrote:

>
> i followed the sticky (along with other various walkthroughts for
> opensuse 11.1) on how to set up the samba share for windows network
> but when i go to my laptop (which runs windows) i can’t access
> anything
>
> help appreciated
>
> Dave
>
>
might be beneficial to post the sticky you’re refering to

Suse 11.1 x64, Kde 4.2beta (unstable repo), Opera 9.x weekly

Have you added any samba users with smbpasswd -a?


Ecky

Ecky’s Profile: http://forums.opensuse.org/member.php?userid=3518
View this thread: http://forums.opensuse.org/showthread.php?t=404325

well i am pretty new to linux so, i just found a how to and followed it
and the machines running windows can only see my the linux computer but
when clicked on windows says the computer doesn’t exist. In other-words
i am kinda lost here.


Kotomine

Kotomine’s Profile: http://forums.opensuse.org/member.php?userid=19398
View this thread: http://forums.opensuse.org/showthread.php?t=404325

I’m assuming this is openSUSE version 11.1 we’re talking about? Yes?

Can you please give us the following diagnostic information. Open a
console/terminal window and enter the commands below. Then copy/paste
the full dialogue you get in the terminal window back here into a reply
post:

Code:

cat /etc/samba/smb.conf

that should telll us if you’ve configured samba to broadcast it’s
resources out to windows machines

Code:

cat /etc/sysconfig/SuSEfirewall2 | egrep “FW_SERVICES_ACCEPT_RELATED_EXT|FW_CONFIGURATIONS_EXT”

that should tell us if you’ve configured the firewall to allow Samba
through

Code:

cat /etc/sysconfig/SuSEfirewall2.d/services/samba-server | egrep “UDP=|BROADCAST=”

that should tell us if you fixed a bug in 11.1 firewall GUIs properly

Complicated expressions – might be easiest to use your mouse to copy
them from the browser and use Edit → Paste in the console window to
enter them.

Luck


‘Drop in and visit some time’
(http://www.swerdna.net.au/linux.html).

swerdna’s Profile: http://forums.opensuse.org/member.php?userid=84
View this thread: http://forums.opensuse.org/showthread.php?t=404325

sorry this took so long i have pretty hectic work hours and yes its suse
11.1.

Code:

cat /etc/samba/smb.conf

smb.conf is the main Samba configuration file. You find a full

commented

version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if

the

samba-doc package is installed.

Date: 2008-12-03

[global]
workgroup = WORKGROUP
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \%L\profiles.msprofile
logon home = \%L%U.9xprofile
logon drive = P:
usershare allow guests = Yes
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody
-s /bin/false %m$
domain logons = No
domain master = No
security = user
netbios name = Server
usershare max shares = 100
[homes]
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes
[profiles]
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700
[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/
[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes
[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No
[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

Share disabled by YaST

[netlogon]

comment = Network Logon Service

path = /var/lib/samba/netlogon

write list = root

[data]
inherit acls = Yes
path = /srv
read only = No

Code:

cat /etc/sysconfig/SuSEfirewall2 | egrep “FW_SERVICES_ACCEPT_RELATED_EXT|FW_CONFIGURATIONS_EXT”

EPT_RELATED_EXT|FW_CONFIGURATIONS_EXT"
FW_CONFIGURATIONS_EXT=“samba-server”

see comments for FW_CONFIGURATIONS_EXT

see comments for FW_CONFIGURATIONS_EXT

FW_SERVICES_ACCEPT_RELATED_EXT=“0/0,udp,137”

see FW_SERVICES_ACCEPT_RELATED_EXT

see FW_SERVICES_ACCEPT_RELATED_EXT

e.g. FW_SERVICES_ACCEPT_RELATED_EXT

See also FW_SERVICES_ACCEPT_RELATED_EXT

Code:

cat /etc/sysconfig/SuSEfirewall2.d/services/samba-server | egrep “UDP=|BROADCAST=”

UDP=“netbios-ns netbios-dgm”
BROADCAST=""


Kotomine

Kotomine’s Profile: http://forums.opensuse.org/member.php?userid=19398
View this thread: http://forums.opensuse.org/showthread.php?t=404325