Problem with Samba in openSUSE 12.1 re systemd-sysvinit


The package systemd is new in 12.1 and it has a few quirks that will be ironed out in time.

I found that Samba will not work properly in 12.1 if the related package “systemd-sysvinit” is installed.
You can try an alternative to the package systemd-sysvinit if you’re having problems with Samba, but you perhaps should get advice before installing the alternative because many other things can be wrongly configured in Samba by new users.

Anyway, the alternative to the RPM systemd-sysvinit is the RPM sysvinit-init. So uninstall systemd-sysvinit and install sysvinit-init.

If you want to know what you do have installed, run this command:

zypper se sysvinit-init systemd-sysvinit

The results will show both RPMs and there will be an “i” showing alongside whichever you currently have installed.

You can go into Yast → Software → Software management to uninstall one and swap it for the other. Remember, systemd-sysvinit is the problematic one, not sysvinit-init.

Update 22 Feb 2012: Samba still functions badly if you have the RPM systemd-sysvinit installed; i.e the bug is not yet resolved
Update 22 Sept 2012: This issue is particular to 12.1 (openSUSE 12.2 doesn’t have this issue).

Just to clarify for me because I’m having issue with CIFS. Do you mean SAMBA or CIFS. I’m getting “input/output errors” when copying data from OS 12.1 64bit to a CIFS share and the data is corrupt on the target. I do not have these issue copying the same data from Windows to the same CIFS share?


Regardless if it was SAMBA or CIFS I followed your instructions and my CIFS problems went away. No more data corruption.


I don’t know about data corruption (haven’t tried to copy data yet), but I got that bug with nmb in systemd: and provided a patch which appears to have solved at least the problem described in my post … but again, I have to try to copy data.

On 09/29/2012 06:06 PM, Operius wrote:
> I removed my pci-e card that i bought mainly for windows and now i’m
> using my onboard again without problems.
> I just had to write a script in /etc/pm/sleep.d to unload the driver
> for it at sleep and load it again at wake-up.
> So the problem isn’t solved, but my system is working so i’m done with
> it.
Glad for you