Problem with restoring my linux

i have a dual boot OpenSUSE/Win7 hp laptop
i recently decided to repair my QuickWEB so according to hp i should change the partitioning of my hard drive so i Backed UP my linux with YAST then i changed the partitioning and it i reinstalled OpenSUSE and there was no problem but when i restored my backup the problem begun after the restart my linux didnt boot !
i got grub error 15 … and i tried to resolve this by using “grub boot disk repair” but it did not found /boot/grub/… and it seems linux does not recognize root partition
i tried it twice (reinstalling linux and restoring files ) and no success after restoring i dont have my linux
it seems to be a problem in grub or mounting root partition
Please help me repair it i really need my prev linux applications and settings
Sorry For bad English :slight_smile:
I have Opensuse12.1 Gnome

If you need to have some help you will have to post here:

  • What programme did you use to do the backup
  • what partition did you do the backup of
  • how did you try to restore (what was the command)

These will be minimal informations people will need to know to give any feedback.

My 2 cents: the backup includes the Windu boot stuff, overwrites your GRUB. My bet is that the install is there, but cannot be found. I suggest you boot from a LiveCD, take over the installed system, and reinstall the bootloader from there. Here’s a link to a howto, it’s in dutch but the commands are the same, use Translate to understand the rest:

Reading the post, opensuse was backed up using YAST. There is a YAST feature to backup things. It seems to produce a tar file. I have never used it and it would not be my first choice. There is also a YAST restore option. It would appear from the post that eventually opensuse was reinstalled without problem and then an attempt was made to restore the backup, probably via YAST. With a partitioning change I suspect the backup has restored what is now an invalid fstab and the file used for booting ( ?).

Yes exactly. :slight_smile:
i used Yast feature for creating backup file on my external hard disk and restoring.
and the problem is that i changed the partitioning and my backup is from when i didnt have changed it

[li]I Used YAST in Opensuse to create backup and restore it![/li]
[li]there is no choice in yast … just system backup…its not backup of entire partition its backup from installed packages and system configuration (even username and Password! and lan settings) the size is about 2.1GB ! [/li]
[*]I Used Yast! again. it asked what packages to restore and i selected all and clicked next! it didnt ask for any other options :frowning:

[/li]O,K. for the future, if the issue is just to restore the /home, you may consider a program making use of rsync (very efficient).
Now to come back to your system:
Let us begin with the obvious - how was / is your partitioning in Linux (do you remember?
Was it the default
/(root) /swap /home or did you use
/boot /(root) /swap /home?
QuickWeb was new to me as I do not use HP. For the future, it would be nice to explain it to non HP users. For what I understand it is a small dedicated fast boot Linux partition to be able to surf the web.
Now what exactly did HP say to do in order to repair the QuickWeb (can you give a short summary of the partitioning you performed?
The partitions are recognized by Linux in /etc/fstab and the command to see it (for the future before you do any partitioning you could save it as a txt file or print it out) is:

cat /etc/fstab

Now in your case you do not have access to Linux, you want to edit text files and you want to have a good and fast overview on partitions (with maybe the possibility to change things.
My advice would be not to use the life CD of openSUSE but for this specialized task to download the iso of Parted Magic life CD (which is a specialized Linux life distribution with a lot of programs to repair, handle, re-size partitions and that will allow to read your current fstab settings, safe it on a txt file and to post it here. It is free software and also for free. So download the ISO (control the check-sum that it is clean and burn it). Start from the CD then read the partition layout and write it down on a paper (or print it if you have a printer attached). Then find you root partition on the system and go to /etc/fsab and copy it to an usb stick and post the content here, so we can see what kind of problem we face.
P.S. Does QuickWeb use the boot manager of Win7?

it was default /(root) /swap /home
sda1 was NTFS Win7 recovery partition (primary)
sda2 was EXT4 /home (Primary)
sda3 was NTFS Win7 partition (primary)
sda4 was /swap (logical)
sda5 was another NTFS partition (logical)
sda6 was /(root) (logical)

I cannot have more than 4 primary partitions in basic partitioning in laptop’s harddrive
so one of the partitions was extended to have more than 4 drives so 3 of my drives was Logical and 3 was primary
and my free NTFS partition (sda5) was one of 3 logical drives.

to install QuickWeb laptop needs a primary patition formatted in fat32 so i couldnt use my sda5 because it was logical not primary!
and all the 4 partitions was used so i decided to change place of sda5 and sda2 and i removed sda5 partition (it was the mistake!) and changed sda2 to NTFS
and as i didnt had my linux i repartitioned the extended drive into 3 (/swap one as /root and one as /home) and installed linux on those!

OK Thanks sure!

OK.ill do it when i got home!
no actually the boot manager is somewhere in bios completely different u do not need too choose it from a menu in boot time. windows boots when u press power button and it boots when u press quickweb button on laptop its kind of limited Linux without any extra apps or ability to install them or remove! its good for listening to music or web surfing or seeing pictures! i got disappointed with it its soooooo limited
looks like needs a little hacking! :wink:
P.S. After restoring i could not login to windows too but repairing windows boot was easier … :slight_smile:

By any chance, is this an UEFI / EFI BIOS? That would be important to know. Did you fix windows with the “fixmbr” command?

may i ask Why its important?
no i fixed it with a application in HirenBoot12 CD which has lots of programs for fixing partitioning and boot

Yes it is very important. I think you cannot solve currently your problem. Why? While in a BIOS the bootloader is on the disk, in UEFI the bootloader has been transferred into the UEFI. Now, in order to use a boot-loader like grub-legacy with that machine, you would need to switch to BIOS mode if available. Alternative (unique as far as I know) would be to uninstall GRUB and to install GRUB2. I do not know the status of grub2 in 12.1. I can tell your that for what I know, GRUB2 will be the default boot manager in 12.2.
GRUB2 handles UEFI but the modalities with which it does are not known to me, as I do not have an UEFI BIOS machine under had up to now.
I found an article of please-try-again that does actually cover the subject. I will ask him if he can assist you in this matter. Good luck.

It’s completely different, doesn’t look for boot loaders in partittion boot sectors but in directories within a special partition (a FAT16 or FAT32 partition called the UEFI partition), doesn’t use the same partition scheme - you need GUID partitioning (GPT) for UEFI and not MBR, doesn’t work with most versions of Legacy Grub (except Fedora’s), uses ELILO as default boot loader under openSUSE, as of 12.1, can use the EFI version of Grub2 (but you have to install it yourself). However the partitions you have are MBR partitions (GPT doesn’t have “logical” partitions - they are all primary). Thus your BIOS must have been switched to Legacy mode. If it was UEFI before, trying to fix partitions with non GPT aware software would have been a bad idea. But you probably never used UEFI, dif you? Trying to install either Windows or Linux on a MBR partitioned hard disk will result in a legacy/MBR installation, which can boot only if the UEFI BIOS is turned off (it often turns off by itself in such a case).

Hi stakanov (I got your PM)

Let me add some details:

  • you can install Grub2 without deinstalling Legacy Grub on 12.1 (of course not in the same boot sector) with updateGrub2, a script included in the package updategrub - available in my repo.
  • What you need on UEFI hardware is grub2-efi, not grub2. It is not the same package. grub2 is going to be in 12.2. I don’t know about grub2-efi. Last time I checked, it wasn’t done.
  • updateGrub2 can be used to install both grub2 and grub2-efi and to refresh Grub menu after updating the kernel or installing other Oses. It hasn’t been widely tested though.

I doubt we have to deal with UEFI in this thread. Many UEFI machines come with a legacy/MBR Windows installation and the UEFI BIOS is deactivated. Installing Linux on UEFI is (still) tricky and doesn’t seem to be possible with all mainboards. Only the openSUSE DVD includes a UEFI (ELILO) setup.

I have no idea what QuickWeb is or does.

Hi please_try_again.
I had my doubts also, but then he claimed that he used not fixmbr so I was in doubt again. Actually this “QuickWeb” is nothing else than a fancy way to use a mini-Linux to do fast boot and allow for email check and few other things. The funny thing is that the producers would hack their hands off for not telling people they are using Linux to do that (it is alike the AV software that does “offline scan” but does not mention - generously - that the AV scan they are running on window offline is using…guess what, a life CD of Linux). But more and more do, as it is cheap, fast and convenient. And probably to do gunny-pig marketing - to test acceptance.
In fact the user became curious about Linux while seeing QuickWeb in action.
Thanks for dropping by. The fact is that I never owned a machine with UEFI/EFI hardware. So it is a bit as a blind would talk verbosely about colors. lol!

You can enable EFI in VirtualBox vms (I never tried).

thanks a lot bros …
I think UEFI is disabled! Actually i dont know much about BIOS Maybe i was wrong! but i installed grub and am using it
finally it fixed
i installed OpenSUSE again … backed up /boot in a flash drive … restored my backup (with a checked check box option about running bootloader configuration )… compared the two /boot folders … the problem was with file “Vmlinuz” in my previous installation the version has changed in new installed it wasnt . so i replaced older one and linux came up but the /home didnt mount and i fixed it in fstab and now every thing is back…Home Sweet Home! :wink: i like it more than windows…

Happy you solved this.

Thank you for the info (now that I know I may try to play :slight_smile: and especially thank you for dropping by. I appreciated.