problem with radeon card

Hi all
I have the following problem with my laptop with leap 15.2 installed

For a while, after the installation all worked fine. Since a week, after login or I get a black screen or the desktop freeze. My laptop has a RADEON HD6750 graphic card.
The only way to start is with the “nomodeset” option in the grub and of course it started in low resolution mode. I read in other thread to insert “radeon.dpm=0” and in this way my system start in high resolution mode.
I wonder if it is the right procedure or there is something I can do to solve the problem. I don’t understand why the system worked well for some time and now no more.


Which DE are you using? Gnome? KDE? Other? Which X session? Xorg? Wayland? Does behavior improve if you switch any of these, e.g. use IceWM instead of KDE or Gnome or XFCE? Wayland is more likely to be trouble with KDE than with Gnome, and really has a lot of work left to do to make it usable for many users.

Please visit this primer, then switch from whichever X DDX driver in current use to the other, either radeon to modesetting, or vice versa. Does it help? inxi -G is a quick way to see which X DDX driver is in use, as you can see an example of below.

Uploading Xorg.0.log from /var/log/ or ~/.local/share/xorg/ to or should be done so we can look for clues to the trouble. The command susepaste is a shortcut to upload to susepaste directly instead of using a web browser. It may report failure even though it succeeded. Check here to see if it succeeded. Be sure the Xorg.0.log file you upload is from a normal boot and login attempt, not one using nomodeset.

Uploading output from the following should also be useful:

sudo journalctl -b | grep ailed

If it’s only two dozen or less lines, pasting here using code tags instead of uploading should be fine.

It should not hurt anything to try radeon.dpm=0 or radeon.dpm=1, as one does it for a single boot by using the E key at the grub menu to append it to the line beginning linu, which only affects the current boot.

I have a similar GPU, though not a laptop, and it’s working fine using TDE:

# inxi -GISay
  Host: gx78b **Kernel: 5.3.18-lp152.47**-default x86_64 bits: 64 compiler: gcc v: 7.5.0
  parameters: noresume mitigations=auto
  Desktop: Trinity R14.0.9 tk: Qt 3.5.0 info: kicker wm: Twin 3.0 dm: TDM
  Distro: openSUSE **Leap 15.2**
  Device-1: AMD Caicos **Radeon HD 6450/7450/8450 / R5 230 OEM**] vendor: Dell
  **driver: radeon** v: kernel bus ID: 01:00.0 chip ID: 1002:6779
  Display: server: **X.Org 1.20.3 driver: modesetting** display ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 120 s-size: 406x254mm (16.0x10.0")
  s-diag: 479mm (18.9")
  Monitor-1: DP-1 res: 1920x1200 hz: 60 dpi: 94 size: 519x324mm (20.4x12.8")
  diag: 612mm (24.1")
  renderer: AMD CAICOS (DRM 2.50.0 / 5.3.18-lp152.47-default LLVM 9.0.1)
  v: 3.3 Mesa 19.3.4 compat-v: 3.1 direct render: Yes
Info:...Shell: Bash v: 4.4.23 running in: konsole **inxi: 3.1.09**

Hi mrmazda

I use KDE with Xorg, my Xorg.0.log contains

This is the results of inxi and it appears that I used radeon DDX

/home/gca> sudo inxi -GISa
System:    Host: voyager Kernel: 5.3.18-lp152.47-default x86_64 bits: 64 compiler: gcc v: 7.5.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.3.18-lp152.47-default root=UUID=7b42fdb9-4837-42ef-8392-f706bd99d260 
           splash=silent resume=/dev/disk/by-id/ata-Samsung_SSD_860_EVO_1TB_S3Z9NB0K419315W-part7 quiet radeon.dpm=0 
           Console: tty 1 dm: SDDM Distro: openSUSE Leap 15.2 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Samsung Co driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0116 
           Device-2: Advanced Micro Devices [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M] driver: radeon 
           v: kernel bus ID: 01:00.0 chip ID: 1002:6741 
           Device-3: Silicon Motion type: USB driver: uvcvideo bus ID: 1-1.4:3 chip ID: 2232:1018 
           Display: server: 1.20.3 compositor: kwin_x11 driver: ati,modesetting,radeon unloaded: fbdev,vesa 
           alternate: intel tty: 237x49 
           Message: Advanced graphics data unavailable in console for root. 
Info:      Processes: 279 Uptime: 5h 12m Memory: 7.68 GiB used: 2.20 GiB (28.6%) Init: systemd v: 234 runlevel: 5 
           target: Compilers: gcc: N/A Shell: bash (sudo) v: 4.4.23 running in: tty 1 inxi: 3.1.00 

and this is the output of journalctl

home/gca> sudo journalctl -b | grep ailed
[sudo] password for root: 
Nov 13 07:00:04 voyager kernel: acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM
Nov 13 07:00:05 voyager kernel: [drm:r600_ring_test [radeon]] *ERROR* radeon: ring 0 test failed (scratch(0x8504)=0xCAFEDEAD)
Nov 13 07:00:07 voyager systemd-udevd[533]: Process '/usr/sbin/tlp auto' failed with exit code 4.
Nov 13 07:00:08 voyager systemd-udevd[507]: Process '/usr/sbin/alsactl restore 0' failed with exit code 99.
Nov 13 07:00:08 voyager kernel: b43: probe of bcma0:1 failed with error -524
Nov 13 07:00:12 voyager NetworkManager[1440]: <info>  [1605247212.7110] device (wlan0): state change: need-auth -> failed (reason 'no-secrets', sys-iface-state: 'managed')
Nov 13 07:00:12 voyager NetworkManager[1440]: <warn>  [1605247212.7125] device (wlan0): Activation: failed for connection 'spaceships2'
Nov 13 07:00:12 voyager NetworkManager[1440]: <info>  [1605247212.7129] device (wlan0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Nov 13 07:00:14 voyager kwin_x11[2111]: kf5.kconfig.core: "\"fsrestore1\" - conversion of \"0,0,0,0\" to QRect failed"
Nov 13 11:52:05 voyager kernel: failed to evaluate ATPX got AE_AML_LOOP_TIMEOUT
Nov 13 11:52:12 voyager kernel: [drm:evergreen_resume [radeon]] *ERROR* evergreen startup failed on resume
Nov 13 11:52:53 voyager kernel: failed to evaluate ATPX got AE_AML_LOOP_TIMEOUT
Nov 13 11:54:16 voyager kernel: failed to evaluate ATPX got AE_AML_LOOP_TIMEOUT
Nov 13 11:54:23 voyager kernel: [drm:evergreen_resume [radeon]] *ERROR* evergreen startup failed on resume
Nov 13 11:55:04 voyager kernel: failed to evaluate ATPX got AE_AML_LOOP_TIMEOUT

Can it help?

In any case, I tryes also to install other distros (mint and fedora) with the same problems. Only win10 works fine

According to the log, X is trying to use two DDX drivers. Let’s try using only one:

sudo zypper rm xf86-video-ati

Once done, the next log should show modeset(0) but not RADEON(G0).