problem with proxy

The proxy I set is not being used or recognized by some apps. For instance dropbox would be able to detect the proxy settings i set using yast>network>proxy while firefox would not recognize it. In firefox i tried using the automatic proxy and using the system proxy. Either of the two won’t detect it. However, when I manually set it in firefox’s preference it would work. For empathy the proxy is not recognized as well. In addition, can I set the proxy in the empathy app itself? I could not locate it. Also the online updates and repository checks recognizes the proxy I set up.

By the way I am using GNOME 3 as my DE. I would also like to share that when I use the network settings > proxy of gnome 3 none of the apps recognize the proxy.


The system proxy module in YaST sets an Environment Variable, so when I change it, I alter the host & port combo, run the test, get the OK.
Then because zypper is clever, I can check access to outside http sites by running that as root. You can check the value by command “echo $http_proxy” in shell.

However, you need to log out for Firefox and the Desktop to see the new variable, unless you use a Terminal/Console Emulator window, where you “login” & then do the “magic” to connect to your display and run firefox by hand.

So make sure Firefox is set to “system proxy settings”, then simply log out of the desktop, relogin and all should be as you expect.

Thanks! I’ll try this out when I get back to school this mon.


It seems that the proxy still cant be recognized by firefox and empathy. dropbox is recognizing it though. Could it be because I am using gnome3? or the latest version of firefox?


I have not only the “latest” firefox, but the alpha version and proxy works for me on many machines.
Very likely you have made a slip, so check step by step; check the box to use same proxy for all protocols. At times I have to start the proxy, think 12.1 M2 something was broke and “chkconfig squid 35” didn’t work.

I don’t run GNOME (version 1 used to crash too much when KDE1 was sooooper solid), but minimal X, LXDE & KDE4 work same. Easy enough to check, open a terminal and “echo $http_proxy”.

Thanks! I’ll redo it again, this time more careful =)