Problem with program that uses virtualbox

I installed a program that uses virtualbox and when I start it up it fails with:

WARNING: The vboxdrv kernel module is not loaded. Either there is no module
         available for the current kernel ( or it failed to
         load. Please recompile the kernel module and install it by

           sudo /etc/init.d/vboxdrv setup

         You will not be able to start VMs until this problem is fixed.
WARNING: The compilation of the vboxdrv.ko kernel module failed during the
         installation for some reason. Starting a VM will not be possible.
         Please consult the User Manual for build instructions.

What could this problem mean? What do I do? I have the latest virtual box installed.


Fedora 11 huh?

It means that the vboxdrv kernel module needs to be compiled to work with the currently running kernel. To do this you need the kernel sources, gcc and make installed on your system to be able to run that command mentioned:

sudo /etc/init.d/vboxdrv setup

This being FC11, you would have to work out how to install those additional packages.

Thank you! I know it’s weird to ask for something on Fedora in the opensuse forums but I have opensuse on all my other comp’s and I’ve found these forums VERY helpful (and timely) and the fedora forums to be non-responsive.

Anyways, I hate to ask this but…

How would I go about getting the kernel sources and put in the right place? I tried this and it didn’t work. I did this:

  1. yumdownloader --source kernel
  2. su -c ‘yum-builddep kernel-’
  3. rpm -Uvh kernel-

it seems to do a bunch of stuff but in the end I’m left with only the rpm and no sources to be found anywhere. What am I doing wrong?

I don’t have a Fedora system, but access to a RHEL system which should be similar in many respects.

You don’t want the .src.rpm package. Those are the raw sources. I think what you want in FC is a package called kernel-devel. Maybe also kernel-headers. Those packages are for compiling extra modules to go with the kernel. Of course make sure the version matches the running kernel, at least for kernel-devel.

Thank you again for your help!

I did the following but am still getting the same error.

yum install kernel-devel- kernel-devel
yum install kernel-devel- kernel-headers

BUT here’s what’s weird!! I did the above command yet when I check /usr/src/kernels, it now shows a folder:**** but that’s not the version I asked for! And it’s NOT my version (according to sysinfo) which is!! How do I fix this?

That directory was probably already there from the initial install of FC11.

By hook or crook you have to install the right version of kernel-devel. Yum will tell you if it succeeded in installing a package and you can check afterwards with rpm -q kernel-devel. So don’t proceed until you have succeeded with this step. You can omit the version if it’s the latest. Maybe you need to refresh your yum cache or something. I don’t have any other ideas for you.

Thanks. I looked at the output when I used yum and it had this:

Loaded plugins: refresh-packagekit                                                             
Setting up Install Process                                                                     
No package kernel-devel- available.                                 
Resolving Dependencies                                                                         
--> Running transaction check                                                                  
---> Package kernel-devel.i586 0: set to be installed 

Weird. No idea where to get my version from or why it’s not there.

I got it to work! Thanks so much for your help!!

I found the correct version at: kernel | Package Info | Koji

Thanks again, I could NOT have done this without your help!!

No worries, enjoy. The VirtualBox forums are also a good source of help.