Problem with plasma widget 'color picker'

I’m on openSUSE Tumbleweed with Plasma 5.27.5 on X11 and I found out that for some reason the default plasma widget color picker doesn’t work properly, whilst applications like KColorChooser and gPick do. The selector’s history panel shows up when clicked (Altough empty) instead the actual selector is greyed out and unresponsive. I’ve tried to reinstall manually the widget to no avail, am I perhaps missing some packages?

Thank you in advance for any kind of advice.

Works just fine here.

Operating System: openSUSE Tumbleweed 20230512
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.105.0
Qt Version: 5.15.9
Kernel Version: 6.3.1-2-default (64-bit)
Graphics Platform: X11

Did you try a new user profile? Did you check the color picker settings (right click on the symbol)?

1 Like

Thank you! The idea of trying a new user profile where the widget was working properly actually made me realize what the problem was, I have on my main profile the composer disabled so switching it on made the widget work again properly. Although I have this problem for the first time, is it there a workaround to have the color picker works without having to enable the composer, I really would rather have it disabled for less CPU workload. Maybe a previous version of the widget worked fine without the composer?