Problem with patch:compiz-1005.noarch

My updater applet keeps reminding me to install patch:compiz-1005.noarch; however, when I try to do so, I get an error message:

PackageKit Error dep-resolution-failed: patch:compiz-1005.noarch conflicts with compiz-kde4.i586 

Similar when I try to solve it by opening Yast2 and taking care of the changes manually:

#### YaST2 conflicts list - generated 2009-07-13 22:45:07 ####

patch:compiz-1005.noarch conflicts with compiz-kde4.i586 < 0.7.8-9.2.1 provided by compiz-kde4-0.7.8-8.20.i586

     ] do not install patch:compiz-1005.noarch

     ] Following actions will be done:
install compiz-kde4-0.7.8-9.2.1.i586 (with vendor change)
  openSUSE Build Service
downgrade of kde4-kgreeter-plugins-4.2.4-3.11.i586 to kde4-kgreeter-plugins-4.1.3-10.3.7.i586
install kde4-kgreeter-plugins-4.1.3-10.3.7.i586 (with vendor change)
  openSUSE Build Service

(... plus a happy list of 419 other downgrades ... )

#### YaST2 conflicts list END ###

I don’t really want to install the patch, but the system keeps bugging me about it. Can’t I switch it off somehow, or tell the system that I won’t install it for good?

Sort your repo list and manage it better you have a repo from OBS enabled I wonder why as it isn’t often needed.(Though maybe 42 not sure)

So clean up your repo list and keep it to the bare minimum less is less hassle. Then make sure priorities are set that the highest(Lowest number) are the ones you’re more concerned with.(Or all equal)

The latest and newest aren’t always the easiest to manage, you choose.

The supported repos are Oss, Non-Oss, Update then on top of them you’re highly unlikely to get any trouble with Packman, KDE42, Graphics card, wireless or web cam repos, due to popularity.

As for the rest good luck.

Thanks for your help, FeatherMonkey. I have to admit that I’m a complete ignoramus when it comes to package management … :shame:

What I don’t understand: I do have a couple of extra repos added, but they are all low priority. KDE 42 and openSUSE 11.1 Update are both given highest priority. Does my problem mean that these two somehow conflict? Should I focus on the Update repo rather than DE 42? :\

Here is a list of my repos, by the way:](

I’ve seen worse I’m not going to say do this or that I’ll presume the repos you have are needed for languages but don’t really know.

Though playground KDE/Repositories - openSUSE why do you have playground…

Alphas, betas and VCS snapshots of KDE applications under development. Packaged by community members

Now pushing it further I tried to get this to happen and don’t know what is happening on your end. When I searched desktop effects I saw kde so used kde in checking for patches it isn’t installed but is installed when I used the generic compiz install, not to mention bought in half of gnome.

OK this is the problem unless you use gnome I would uninstall compiz, search in yast by pattern => desktop effects uninstall, apply then choose compiz-kde not compiz-kde4. Should have you back up and running

Ah, you did the magic, my friend! :slight_smile:

Thanks a lot!

No problem glad it solved it, hopefully they’ll get on top of this repo mess for the next release.