Problem with OS-12.3 kernel bug on


I have a problem with OS-12.3 kernel. After updating from 12.2 via installation DVD from OpenSuSE my nfs-filesystem won’t mount. Instead I got a an error message shown below.

My system is:

Intel(R) Core™ i5-3570 CPU @ 3.40GHz

BIOS Info: #0
Vendor: “FUJITSU // American Megatrends Inc.”
Version: “V4.6.5.3 R1.11.0 for D3161-A1x”
Date: “07/16/2012”
Start Address: 0xf0000
ROM Size: 8192 kB
Features: 0x0d03000000013c099880
PCI supported
BIOS flashable
BIOS shadowing allowed
CD boot supported
Selectable boot supported
EDD spec supported
Print Screen supported
8042 Keyboard Services supported
Serial Services supported
Printer Services supported
ACPI supported
USB Legacy supported
BIOS Boot Spec supported
System Info: #1
Manufacturer: “FUJITSU”
Product: “ESPRIMO P710”
Serial: “YLHW006889”
UUID: undefined, but settable
Wake-up: 0x03 (APM Timer)
Board Info: #2
Manufacturer: “FUJITSU”
Product: “D3161-A1”
Version: “S26361-D3161-A1”
Serial: “B21649E8”
Type: 0x0a (Motherboard)
Features: 0x09
Hosting Board
Chassis: #3
Chassis Info: #3
Manufacturer: “FUJITSU”
Version: “C$PXW4”
Serial: “YLHW006889”
Type: 0x06 (Mini Tower)
Bootup State: 0x03 (Safe)
Power Supply State: 0x03 (Safe)
Thermal State: 0x03 (Safe)
Security Status: 0x03 (None)

I have also tried a newer kernel from OpenSuSE-kernel-repository for 12.3 as well as failsafe, but with no sucess. It is always the same error. It triggers immediately after a nfs-mount command. Everything else seams to work.

Below is content of messages:

2013-03-26T13:51:10.424306+01:00 wptl84 kernel: 8845.408930] BUG: unable to handle kernel paging request at ffffffffffffd8ee2013-03-26T13:51:10.424321+01:00 wptl84 kernel: 8845.408936] IP: <ffffffffa0cf07fd>] nfs4_set_client.isra.5+0x8d/0x100 [nfsv4]
2013-03-26T13:51:10.424322+01:00 wptl84 kernel: 8845.408951] PGD 1a0e067 PUD 1a0f067 PMD 0
2013-03-26T13:51:10.424323+01:00 wptl84 kernel: 8845.408955] Oops: 0002 #3] SMP
2013-03-26T13:51:10.424326+01:00 wptl84 kernel: 8845.408958] Modules linked in: bnep bluetooth rfkill fuse nfsv4 auth_rpcgss nfs fscache lockd sunrpc cpufreq_conservative cpufreq_userspace cpufreq_powersave acpi_cpufreq snd_hda_codec_hdmi mperf snd_hda_codec_conexant coretemp kvm_intel kvm snd_hda_intel snd_hda_codec snd_hwdep crc32c_intel snd_pcm_oss ghash_clmulni_intel tpm_infineon snd_pcm aesni_intel snd_seq snd_timer ablk_helper cryptd iTCO_wdt lrw aes_x86_64 joydev tpm_tis tpm tpm_bios ppdev snd_seq_device iTCO_vendor_support lpc_ich mei xts button video parport_pc parport snd_mixer_oss i2c_i801 mfd_core e1000e gf128mul snd hid_logitech_dj serio_raw soundcore sr_mod cdrom pcspkr microcode snd_page_alloc sg usb_storage autofs4 hid_generic usbhid xhci_hcd ehci_hcd usbcore usb_common fan thermal processor thermal_sys scsi_dh_alua scsi_dh_hp_sw scsi_dh_rdac scsi_dh_emc scsi_dh [last unloaded: nvidia]
2013-03-26T13:51:10.424328+01:00 wptl84 kernel: 8845.409011] CPU 0
2013-03-26T13:51:10.424329+01:00 wptl84 kernel: 8845.409015] Pid: 7273, comm: mount.nfs Tainted: P D O 3.7.10-1.1-default #1 FUJITSU ESPRIMO P710/D3161-A1
2013-03-26T13:51:10.424330+01:00 wptl84 kernel: 8845.409018] RIP: 0010:<ffffffffa0cf07fd>] <ffffffffa0cf07fd>] nfs4_set_client.isra.5+0x8d/0x100 [nfsv4]
2013-03-26T13:51:10.424331+01:00 wptl84 kernel: 8845.409028] RSP: 0018:ffff880403e69b38 EFLAGS: 00010287
2013-03-26T13:51:10.424332+01:00 wptl84 kernel: 8845.409031] RAX: ffffffffffffd8de RBX: ffff880403e69b50 RCX: ffffffffa0c57eb0
2013-03-26T13:51:10.424333+01:00 wptl84 kernel: 8845.409032] RDX: 0000000000000004 RSI: ffffffffa0c59254 RDI: 0000000000000286
2013-03-26T13:51:10.424334+01:00 wptl84 kernel: 8845.409034] RBP: ffff880407d4c000 R08: 2018000000000000 R09: 04055a51900c0000
2013-03-26T13:51:10.424335+01:00 wptl84 kernel: 8845.409036] R10: fbdca6afc6886403 R11: ffff880406394800 R12: ffff880404fdfec0
2013-03-26T13:51:10.424336+01:00 wptl84 kernel: 8845.409037] R13: ffff880403e69bd8 R14: ffff880403e69d70 R15: ffff880403e69d70
2013-03-26T13:51:10.424336+01:00 wptl84 kernel: 8845.409040] FS: 00007fb5c5aaf800(0000) GS:ffff88041dc00000(0000) knlGS:0000000000000000
2013-03-26T13:51:10.424337+01:00 wptl84 kernel: 8845.409042] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
2013-03-26T13:51:10.424338+01:00 wptl84 kernel: 8845.409043] CR2: ffffffffffffd8ee CR3: 0000000404873000 CR4: 00000000001407f0
2013-03-26T13:51:10.424339+01:00 wptl84 kernel: 8845.409045] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
2013-03-26T13:51:10.424339+01:00 wptl84 kernel: 8845.409047] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
2013-03-26T13:51:10.424340+01:00 wptl84 kernel: 8845.409049] Process mount.nfs (pid: 7273, threadinfo ffff880403e68000, task ffff880405e86080)
2013-03-26T13:51:10.424341+01:00 wptl84 kernel: 8845.409050] Stack:
2013-03-26T13:51:10.424342+01:00 wptl84 kernel: 8845.409052] ffff880403e69d70 ffff880407d4c160 0000000000000003 0000000000000000
2013-03-26T13:51:10.424343+01:00 wptl84 kernel: 8845.409056] ffff880404fdfbe0 ffff88040413dcf8 0000000000000010 ffffffffa0d03ca0
2013-03-26T13:51:10.424343+01:00 wptl84 kernel: 8845.409059] 0000000000000006 ffffffff81a6ba80 0000000000000000 ffff88040413dc00
2013-03-26T13:51:10.424344+01:00 wptl84 kernel: 8845.409062] Call Trace:
2013-03-26T13:51:10.424345+01:00 wptl84 kernel: 8845.409126] <ffffffffa0cf163a>] nfs4_create_server+0xda/0x390 [nfsv4]
2013-03-26T13:51:10.424346+01:00 wptl84 kernel: 8845.409177] <ffffffffa0cea671>] nfs4_remote_mount+0x31/0x80 [nfsv4]
2013-03-26T13:51:10.424347+01:00 wptl84 kernel: 8845.409217] <ffffffff8116a7a5>] mount_fs+0x45/0x1d0
2013-03-26T13:51:10.424347+01:00 wptl84 kernel: 8845.409224] <ffffffff81183123>] vfs_kern_mount+0x73/0x120
2013-03-26T13:51:10.424348+01:00 wptl84 kernel: 8845.409234] <ffffffffa0cea5f0>] nfs_do_root_mount+0x90/0xe0 [nfsv4]
2013-03-26T13:51:10.424349+01:00 wptl84 kernel: 8845.409275] <ffffffffa0cea95a>] nfs4_try_mount+0x3a/0xc0 [nfsv4]
2013-03-26T13:51:10.424350+01:00 wptl84 kernel: 8845.409319] <ffffffffa0cacff5>] nfs_fs_mount+0x255/0xcd0 [nfs]
2013-03-26T13:51:10.424351+01:00 wptl84 kernel: 8845.409340] <ffffffff8116a7a5>] mount_fs+0x45/0x1d0
2013-03-26T13:51:10.424351+01:00 wptl84 kernel: 8845.409344] <ffffffff81183123>] vfs_kern_mount+0x73/0x120
2013-03-26T13:51:10.424352+01:00 wptl84 kernel: 8845.409349] <ffffffff81183aa3>] do_kern_mount+0x53/0x110
2013-03-26T13:51:10.424353+01:00 wptl84 kernel: 8845.409354] <ffffffff81185574>] do_mount+0x334/0x900
2013-03-26T13:51:10.424354+01:00 wptl84 kernel: 8845.409361] <ffffffff81185bd8>] sys_mount+0x98/0xf0
2013-03-26T13:51:10.424355+01:00 wptl84 kernel: 8845.409367] <ffffffff8154f2ed>] system_call_fastpath+0x1a/0x1f
2013-03-26T13:51:10.424356+01:00 wptl84 kernel: 8845.409374] <00007fb5c51a8f4a>] 0x7fb5c51a8f49
2013-03-26T13:51:10.424357+01:00 wptl84 kernel: 8845.409375] Code: 00 00 04 00 74 06 f0 80 4c 24 18 01 8b 4c 24 70 48 8b b4 24 80 00 00 00 4c 89 ca 48 89 df e8 6b 08 fb ff 48 3d 00 f0 ff ff 77 54 <f0> 80 48 10 20 48 89 45 00 f6 05 c4 b5 f6 ff 02 75 2d 31 db 48
2013-03-26T13:51:10.424358+01:00 wptl84 kernel: 8845.409407] RIP <ffffffffa0cf07fd>] nfs4_set_client.isra.5+0x8d/0x100 [nfsv4]
2013-03-26T13:51:10.424359+01:00 wptl84 kernel: 8845.409415] RSP <ffff880403e69b38>
2013-03-26T13:51:10.424360+01:00 wptl84 kernel: 8845.409417] CR2: ffffffffffffd8ee
2013-03-26T13:51:10.424361+01:00 wptl84 kernel: 8845.409420] — end trace 968f65d1c3182b85 ]—

Please, please, please. Always copy/paste your computer texts from the terminal emulator in between CODE tags when you post them. You get CODE thags by clicking on the # button in the toolbar of the post editor.

On 03/26/2013 09:36 AM, hcvv wrote:
> Please, please, please. Always copy/paste your computer texts from the
> terminal emulator in between CODE tags when you post them. You get CODE
> thags by clicking on the # button in the toolbar of the post editor.

One other thing to consider. Your trace shows that your kernel is tainted with
the P flag for a proprietary module (nvidia). In addition, that module was the
last unloaded. Unless you can reproduce the problem without ever loading that
module, kernel developers are not likely to seriously work on your problem. That
module contains a binary blob that cannot be evaluated.

Sorry for not copying!

OK, I have removed all nvidia-stuff, but the error remains the same. Here only the start of the bug:

wptl84 systemd[1]: Mounting /home…wptl84 kernel: 40.532903] BUG: unable to handle kernel paging request at ffffffffffffd8ee
wptl84 kernel: 40.532961] IP: <ffffffffa05540ed>] nfs4_set_client.isra.5+0x8d/0x100 [nfsv4]
wptl84 kernel: 40.533022] PGD 1a0e067 PUD 1a0f067 PMD 0
wptl84 kernel: 40.533057] Oops: 0002 #2] PREEMPT SMP
wptl84 kernel: 40.533090] Modules linked in: nfsv4 auth_rpcgss nfs fscache lockd sunrpc cpufreq_conservative cpufreq_userspace cpufreq_powersave acpi_cpufreq mperf coretemp kvm_intel kvm snd_hda_codec_hdmi snd_hda_codec_conexant crc32c_intel snd_hda_intel snd_hda_codec ghash_clmulni_intel aesni_intel ablk_helper cryptd lrw aes_x86_64 snd_hwdep snd_pcm_oss xts gf128mul snd_pcm nouveau snd_seq snd_timer snd_seq_device ppdev parport_pc ttm drm_kms_helper drm snd_mixer_oss tpm_infineon i2c_i801 snd iTCO_wdt iTCO_vendor_support parport microcode i2c_algo_bit tpm_tis tpm sr_mod cdrom soundcore e1000e serio_raw lpc_ich mei mfd_core tpm_bios mxm_wmi wmi snd_page_alloc pcspkr sg video button autofs4 xhci_hcd fan thermal processor thermal_sys scsi_dh_alua scsi_dh_hp_sw scsi_dh_rdac scsi_dh_emc scsi_dh