Problem with openSuse's oss and non-oss repositories

I have installed openSuse 12.1 64-bit. Whenever I update the package data on my computer I get the following errors for oss and non-oss repositories as:

  1. Non-oss repo:

URL: Index of /distribution/12.1/repo/non-oss (Medium 1)
reason: File ‘/repodata/repomd.xml’ not found on medium ‘http://download.opensuse.org/distribution/12.1/repo/non-oss/

  1. Oss repo:

URL: Index of /distribution/12.1/repo/oss (Medium 1)
reason: File ‘/repodata/repomd.xml’ not found on medium ‘http://download.opensuse.org/distribution/12.1/repo/oss/

This is serious problem. I cannot install restricted-codecs for kaffine.

These repositories are added for you and work just fine. If for some reason you removed them and tried to add them back in, when you specify the URL, make sure to uncheck the option at the bottom that says Download repository description files. I suggest you remove the ones you have, do an add, enter the URL again, but uncheck the option as I suggest and see what you get.

Thank You,

Hi
It could also be MirrorBrain sending you to a faulty mirror. Hard code
a local mirror in your locale should help;
http://en.opensuse.org/Portal:Mirrors


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.0-1.2-desktop
up 3:26, 3 users, load average: 0.07, 0.04, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

I don’t think you got the problem. Its not working. The refresh on these repos fails.

I removed the repositories and added the same URLs with the option selected in Yast as “Specify URL” and it worked fine.