Problem with openSuse12.1 and Gnome3 graphics

Hello,

I upgraded my system to openSuse 12.1 from 11.4 and installed gnome3. But since then, graphics effects stopped working, also if i try enabling it, it shows gnome error page - “Oopps something went wrong!!” with a logout button. I have ATI graphics card with dell inspiron machine

Here is how my window manager looks like -

https://lh6.googleusercontent.com/-a7iPA8yi2dk/T0dHbDKSVmI/AAAAAAAACfM/jXSj1PeOstI/s640/bad_dolphin.png

Provided you don’t have an old legacy ATI card:

I tried this, and installed atiupgrade. After installation and restart, when I logged in to the device, I everything disappeared with only desktop background there. There is no more top bar in gnome 3, nor Alt+F1 works for opening anything. I somehow opened firefox, but its top title bar is missing.

Please let me if I missed something. How can I fix this to get things working.

Thanks!!

Well, it’s a good and a bad news. The good news is that Gnome shell is now starting (you were using Gnome in fallback mode before). The bad news is that Gnome shell is not working properly. If it’s an onboard graphics card, one possible reason would be that it doesn’t have enough memory. You can fix it by increasing the video memory in BIOS setup. If it’s not possible or doesn’t help, you should enforce gnome fallback. There are several ways to do it. Maybe you could save the following code in a file called /usr/share/xsessions/gnome-fallback.desktop:

[Desktop Entry]
Name=GNOME Classic (No effects)
Comment=This session logs you into GNOME with the traditional panel without any graphical effect.
Exec=gnome-session --session=gnome-fallback
TryExec=gnome-session
Icon=
Type=Application

At next login, you should be able to select “GNOME Classic (No effects)”.

If I remove fglrx drivers, it works again in fallback mode. In this fallback mode, If I run

cat /var/log/Xorg.0.log

it shows I am using RADEON drivers currently. So, do i need to disable RADEON drivers somehow before getting fglrx to work ?

If i run " /sbin/lspci " then i can see that I have below graphics card -

 02:00.0 VGA compatible controller: ATI Technologies Inc Manhattan [Mobility Radeon HD 5400 Series]

No. You don’t need to disable anything, at least not if you use atiupgrade. The script normally takes care of everything, and the rpm install script of the fglrx package (created by atiupgrade) takes care of the rest. Like any piece of software, it could have bugs if it encounters an unexpected situation. But it works fine in the majority of cases. How did you remove the fglrx driver? The right way is to uninstall the fglrx package. The rpm file should still be in the directory /usr/share/atiupgrade. You can reinstall it anytime with zypper in like any other package. No need to re-run atiupgrade to reinstall this version.

Yes, it should be supported AFAIK. Mine is much older:

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon HD 2400 XT

Did you try gnome-fallback with the fglrx driver as I suggested in my previous post?

Could you please post the ouptut of this command:

hwinfo --gfxcard

Output is -


21: PCI 200.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.319]
  Unique ID: B35A.JjrkswYkO41
  Parent ID: vSkL.3YjmaDKIZ08
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: graphics card
  Model: "ATI VGA compatible controller"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x68e0 
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x0456 
  Driver: "radeon"
  Driver Modules: "drm"
  Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
  Memory Range: 0xcfee0000-0xcfefffff (rw,non-prefetchable)
  I/O Ports: 0x2000-0x2fff (rw)
  Memory Range: 0xcfe00000-0xcfe1ffff (ro,non-prefetchable,disabled)
  IRQ: 43 (237971 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001002d000068E0sv00001028sd00000456bc03sc00i00"
  Driver Info #0:
    Driver Status: radeon is active
    Driver Activation Cmd: "modprobe radeon"
  Driver Info #1:
    Driver Status: fglrx is not active
    Driver Activation Cmd: "modprobe fglrx"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #8 (PCI bridge)

Primary display adapter: #21

It looks OK to me. I was wondering if you had a hybrid gaphics card (ATI + something else), but you don’t.
How much RAM and video RAM do you have?

Initially I uninstalled fglrx with yast -> Software Installer. I re installed it again with “zypper in” and added above configuration to gnome-fallback.destop. I tried logging in to the GNOME Classic, but that also has same effect as normal GNOME - no title bars, no ALT+F* working. I tried finding video RAM option in bias, but nothing found.

I have 4GB RAM and 1GB ATI graphics card.

Currently logged in to system with IceWM desktop, even KDE isn’t being displayed properly.

What about creating a new user and trying to log in in Gnome and/or KDE?

That exists only if your gaphics card is on the mainboard.

It’s plenty. It’s not the problem then.

Wrong glx driver? Conflict with some mesa driver? Compositing explicitely turned off in xorg.conf? It’s an upgrade, right? Not a clean install? Do you see some valuable info in /var/log/Xorg.0.log?

On 2012-02-24 11:36, rtdp wrote:

> I tried this, and installed atiupgrade. After installation and restart,
> when I logged in to the device, I everything disappeared with only
> desktop background there. There is no more top bar in gnome 3, nor
> Alt+F1 works for opening anything. I somehow opened firefox, but its top
> title bar is missing.

Try a new user.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Trying with creating a new user and logging in with it.

Wrong glx driver? Conflict with some mesa driver? Compositing explicitely turned off in xorg.conf? It’s an upgrade, right? Not a clean install? Do you see some valuable info in /var/log/Xorg.0.log?

Yes, this is not clean install. System was 11.4 with kde and gnome 2, and then upgrade to 12.1 then upgrade with gnome 3.

My xorg.conf looks as -


Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
	Screen         "amdcccle-Screen[2]-1" RightOf "aticonfig-Screen[0]-0"
EndSection

Section "Module"
EndSection

Section "ServerFlags"
	Option	    "Xinerama" "off"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Monitor"
	Identifier   "0-LVDS"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
	Option	    "TargetRefresh" "60"
	Option	    "Position" "0 0"
	Option	    "Rotate" "normal"
	Option	    "Disable" "false"
	Option	    "PreferredMode" "1366x768"
EndSection

Section "Monitor"
	Identifier   "0-CRT1"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
	Option	    "TargetRefresh" "60"
	Option	    "Position" "0 0"
	Option	    "Rotate" "normal"
	Option	    "Disable" "false"
	Option	    "PreferredMode" "1600x900"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	Option	    "Monitor-LVDS" "0-LVDS"
	BusID       "PCI:2:0:0"
EndSection

Section "Device"
	Identifier  "amdcccle-Device[2]-1"
	Driver      "fglrx"
	Option	    "Monitor-CRT1" "0-CRT1"
	BusID       "PCI:2:0:0"
	Screen      1
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "amdcccle-Screen[2]-1"
	Device     "amdcccle-Device[2]-1"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection


My logs from /var/logs/Xorg.0.log can be seen here.

I created new user, logged in to KDE, which works very well with all awesome graphic effects. But GNOME still fails as earlier for this new user.

On 2012-02-24 14:26, rtdp wrote:
> Yes, this is not clean install. System was 11.4 with kde and gnome 2,
> and then upgrade to 12.1 then upgrade with gnome 3.

What upgrade method exactly?


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I changed repositories from 11.1 to 12.1 and then used online upgrade.

I changed xinerama to be on


Option	    "Xinerama" "on"

and now what i see inside the gnome 3 is this -

https://lh3.googleusercontent.com/-0COyLystBJ8/T0eZOJ4Xl8I/AAAAAAAACfk/ea8s7uK28yE/s640/new_sreen.png

Now, what should be corrected to get it working well ?

On 2012-02-24 15:06, rtdp wrote:
>
> robin_listas;2443123 Wrote:
>>
>> What upgrade method exactly?
>
> I changed repositories from 11.1 to 12.1 and then used online upgrade.

Ok. Then you have to review the list of .rpmorig and .rpmnew files.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I would really appreciate a bit more details or any link. I checked with rpmconfigcheck as -


rain@linux-vai9:~> sudo /etc/init.d/rpmconfigcheck 
root's password:
Searching for unresolved configuration files
                                                                                                                           done
Please check the following files (see /var/adm/rpmconfigcheck):
    /etc/apache2/default-server.conf.rpmsave
    /etc/inittab.rpmnew
    /etc/named.conf.rpmnew
    /etc/nginx/nginx.conf.rpmsave
    /etc/postfix/main.cf.rpmnew
    /etc/postfix/master.cf.rpmnew
    /etc/pulse/client.conf.rpmnew
    /etc/samba/smb.conf.rpmnew
    /etc/sysconfig/SuSEfirewall2.rpmnew
    /etc/sysconfig/SuSEfirewall2.d/services/apache2.rpmsave
    /usr/lib/jvm/java-1.6.0-openjdk-1.6.0/jre/lib/fontconfig.SuSE.properties.rpmsave
    /usr/share/fonts/encodings/encodings.dir.rpmsave
    /usr/share/fonts/truetype/fonts.dir.rpmorig
    /usr/share/fonts/truetype/fonts.scale.rpmorig
    /usr/share/kde4/config/kdm/kdmrc.rpmnew

On 2012-02-24 15:36, rtdp wrote:
>
> robin_listas;2443128 Wrote:
>>
>> Ok. Then you have to review the list of .rpmorig and .rpmnew files.
>>
>
> I would really appreciate a bit more details or any link. I checked
> with rpmconfigcheck as -
>


http://en.opensuse.org/SDB:Offline_upgrade#Stale_configuration_files

Your list is quite short :slight_smile:

But I doubt it is affecting your current issue. Only the fonts, perhaps.
Inittab I dunno. Careful there.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I doubt using Xinerama will solve the problem. It’s deprecated and lesss and less supported. You will probably save time with a clean install. fglrx seems to be working as far as I can tell. Your Gnome is in fallback though (but if you did log in in fallback mode, it’s normal).