Problem with opensuse 11.3 and Monitor

Hi to all
I have this problem:
I have some computers with opensuse 11.3 installed. This computers starts without monitor plugged and the autologin is enabled.
Sometimes I need to plug in the monitor and check their status (i can’t use ssh console and other similar stuff… I need to use physical monitor).
The problem is that there isnt signal from the VGA and than the monitor is black.
If I starts the computers with monitor plugged in everything works fine. if I use ssh everything works fine, but I need to use the physical monitor.
My xorg configuration is the default one.
Is there a way to force to enable the VGA even if the monitor is unplugged?
Thanks

Hi
I would assume from your question that you need to run a GUI application? You can do this with ssh, you just need a X server running on the local machine.

Sounds like it may go to sleep, but since there is no screen…hard to check unless you can run a local X server.

What client are you ssh’ing from?

Else look at installing something like Nx from nomachine on the systems and connect via the no machine client.

PS, 11.3 is way out of support…

On 12/10/2012 06:26 PM, malcolmlewis wrote:
> PS, 11.3 is way out of support…

yep, 11.3 is past its end of life (cite:
http://en.opensuse.org/Lifetime, and has had NO security
patches for 11 months. It therefore now has several vulnerabilities and
should not be exposed to untrusted networks like the internet or even
internal networks which might be attacked from the inside by (say) a
disgruntled employee, co-worker or student out to do damage…

you are advised to take steps to secure those machines.
currently openSUSE 12.1 and 12.2 are supported and the only in-place
upgrade path supported from 11.3 to either of those versions is here:
http://tinyurl.com/7l4m2td but, personally i wouldn’t do it that way,
instead i’d do a format and fresh install (of course, after a data backup)

if you need a longer life distro i’d suggest you look at SUSE Linux
Enterprise Server at <suse.com>, Red Hat or CentOS…others here may
have other opinions: like if you upgrade to 11.4 and then to Evergreen
that combo is supported until July 2014 <http://tinyurl.com/4aflkpy>


dd http://tinyurl.com/DD-Caveat

Is there a way to force to enable the VGA even if the monitor is unplugged?
Thanks

IIRC, it is possible to force an output, either via xorg.conf, or dynamically via xrandr. You might want to check out the man pages first:

man intel

Thanks for the response malcolmlewis

My Company developed an application, it can be used with or without the GUI. But sometimes I have to use the application with the GUI support!! In this cases, often, I am not able to connect via SSH. I need to plug the monito in.

It may be…infact I tried to connect some resistance to the VGA connector just to simulate the monitor impedance, this solution works fine but I would like to use a Software solution.

I can connect remotely with this machine through PUTTY or VNC

Not all the time I have the network access!! I have to use the montior!!

I know but on this machines I can’t upgrade the Operating System

Thanks for the response dd

However all the machines haven’t the Internet connection, they are in a private cabled LAN.

Thank you deano_ferrari

Unfortunately I’m not an expert of this argument, If you can give to me more hints I will appreciate. I never work with Xorg or xrandr.

I haven’t got a headless server to practice on, so I’ll point you at this guide

Intel Linux Graphics: Dual Head Setup How To

It discusses manual configuration of the Xorg with the intel driver.

You could try a basic /etc/X11/xorg.conf like this (no promises though)

Section "Monitor"
Identifier "Monitor0"
HorizSync 45.0 - 100.0 
VertRefresh 50.0 - 80.0
Option "Enable"  "true"    
EndSection

Section "Device"    
Identifier "Device0"
Driver "intel"
Option "monitor-VGA" "Monitor0"
EndSection

Section "Screen"    
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Note the line

Option "monitor-VGA" "Monitor0"

You will need to use the correct ‘xrandr’ output name for your VGA output (although I think I’ve got it right for the intel driver). You can get this info from the server (booted with the display attached) via the ‘xrandr’ command, or by examining /var/log/Xorg.0.log for detected output names.

This line

Option "Enable"  "true"

should force the VGA output regardless of whether a monitor is attached or not.

I never work with Xorg or xrandr.

You’ll need to learn these skills, because if the above doesn’t work, you may need to remove or edit xorg.conf from runlevel 3 (without X running).

Thanks to All
the solution is very easy, I added (trough Yast) the follow string: “video=VGA-1:e” to the grub default option.
The full command line is this one:
kernel /boot/vmlinuz-2.6.34-12-desktop root=/dev/sda6 resume=/dev/sda5 splash=silent quiet showopts video=VGA-1:e vga=0x31a

Yep, that will work too with KMS drivers. I wasn’t sure if 11.3 was recent enough to take advantage of that kernel parameter, hence the Xorg approach.

Thanks to all.
How can I do to close this thread??

Not needed. Others may come searching for help with the same/similar issue, and can add to the thread as necessary. :slight_smile: