Problem with openal-soft since fresh install of 12.3

First, I should say that X-Plane 10 worked flawlessly on openSUSE 12.2 This is a new problem. I should also mention that X-Plane is a stand-alone program. It does not rely on Wine. It runs on it’s own in Windows, Mac, or Linux. The only variable between OSs is which executable you open.

Since I installed openSUSE 12.3 I am having a problem that seems to have been narrowed down to openal-soft.

When I filed a bug with the supplier (Laminar Research) and sent the crash reports (not human readable) to them, the wrote back saying that openal is crashing and that is why X-Plane is crashing. When I start X-Plane, the main window crashes immediately and offers to send a crash report. It makes no difference if I run the 32 bit or 64 bit version.

Any time I run “openal-info”, the output ends with a seg fault. I have not found a way to get any kind of verbose output for troubleshooting. Here is the only output that I get:

# openal-info
Available playback devices:
    ALSA Default
    Xonar D2X, Multichannel (CARD=D2X,DEV=0)
    Xonar D2X, Digital (CARD=D2X,DEV=1)
Available capture devices:
    ALSA Default
    Xonar D2X, Multichannel (CARD=D2X,DEV=0)
    Xonar D2X, Digital (CARD=D2X,DEV=1)
Default playback device: ALSA Default
Default capture device: ALSA Default
ALC version: 1.1
Segmentation fault

I thought of reporting this in the games forums, but since the problem seems to be caused by changes to openal, i thought that multimedia might be more pertinent. If it is not correct, please feel free to bump it into games.

Anyone have any thoughts about this problem? I have no idea what might have changed with openal between 12.2 and 12.3

I found my answer, thanks to help from the authors of X-Plane. They helped me to debug.

It seems that in this version (12.3) of openSUSE, openal will not work without pulse audio.

I have always removed pulse right after an openSUSE install as it does not do a good job with high end audio equipment. I have always used straight alsa.

openal-info still degfaults, but the message is different now.

AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"

It displays that error even though pulse is installed and active. I have been unable to locate any pulse backends that might be missing. Anyway, I have X-Plane working now. I just have to remember to enable pulse before I try to open X-Plane, and disable it when I am done.