problem with onboard network card {gigabit}

hi, i installed SUSE 11 yesterday and i’m having troubles in connecting to the internet from SUSE.

I also have XP on my pc and the ethernet works fine on that but there is some problem with suse.

i used this command :

dmesg | grep eth0

and got this error message :

eth0: (PCI Express:2.5GB/s:Width x1) 00:1b:fc:5d:85:3e
eth0: Intel(R) PRO/1000 Network Connection
eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
ADDRCONF(NETDEV_UP): eth0: link is not ready

followed that up with this command

ifconfig eth0 up

and then typed

dmesg | grep eth0

again and got the same error message as earlier…

can you guys please suggest me what to do ??

On Wed, 2008-08-20 at 13:26 +0000, 12345 wrote:

>
> Code:
> --------------------
> eth0: (PCI Express:2.5GB/s:Width x1) 00:1b:fc:5d:85:3e
> eth0: Intel(R) PRO/1000 Network Connection
> eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
> ADDRCONF(NETDEV_UP): eth0: link is not ready
> --------------------
> followed that up with this command
>
> Code:
> --------------------
> ifconfig eth0 up
> --------------------
> and then typed
> Code:
> --------------------
> dmesg | grep eth0
> --------------------
> again and got the same error message as earlier…
>
> can you guys please suggest me what to do ??

Not sure. It’s like the card isn’t actually
connected to the network. Is it?

On Wed, 20 Aug 2008 13:26:03 GMT
12345 <12345@no-mx.forums.opensuse.org> wrote:

>
> Code:
> --------------------
> eth0: (PCI Express:2.5GB/s:Width x1) 00:1b:fc:5d:85:3e
> eth0: Intel(R) PRO/1000 Network Connection
> eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
> ADDRCONF(NETDEV_UP): eth0: link is not ready
> --------------------

That looks to be a PCIex1 card plugged into your computer…

There’s no cable plugged into it. Do you have multiple nic’s in that
machine? Is your cable plugged into the proper socket?

Try:

dmesg | grep eth[0-9]

and see how many ethernet devices are in the system. I bet the one you think
you’re using isn’t the one you think you’re using.

Loni


L R Nix
lornix@lornix.com

ok…guys here are 2 separate runs of some commands that i’ve mentioned above {along with a few new commands}




**linux:/home/user1/Desktop # dmesg | grep eth**
Parsing all Control Methods:
Table [DSDT](id 0001) - 701 Objects with 56 Devices 206 Methods 26 Regions
Parsing all Control Methods:
Table [SSDT](id 0002) - 9 Objects with 0 Devices 3 Methods 0 Regions
Parsing all Control Methods:
Table [SSDT](id 0003) - 7 Objects with 0 Devices 4 Methods 0 Regions
Initializing Device/Processor/Thermal objects by executing _INI methods:.
Executed 1 _INI methods requiring 0 _STA executions (examined 62 objects)
ACPI Error (psparse-0537): Method parse/execution failed \_PR_.CPU1._OSC] (Node dec32888), AE_ALREADY_EXISTS
ACPI: Marking method _OSC as Serialized
ACPI Error (psparse-0537): Method parse/execution failed \_PR_.CPU1._PDC] (Node dec3289c), AE_ALREADY_EXISTS
ACPI: Marking method _PDC as Serialized
ACPI Error (psparse-0537): Method parse/execution failed \_PR_.CPU2._OSC] (Node dec327d4), AE_ALREADY_EXISTS
ACPI: Marking method _OSC as Serialized
ACPI Error (psparse-0537): Method parse/execution failed \_PR_.CPU2._PDC] (Node dec327e8), AE_ALREADY_EXISTS
ACPI: Marking method _PDC as Serialized
Driver 'sd' needs updating - please use bus_type methods
eth0: (PCI Express:2.5GB/s:Width x1) 00:1b:fc:5d:85:3e
eth0: Intel(R) PRO/1000 Network Connection
eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
Driver 'sr' needs updating - please use bus_type methods
eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
eth0: 10/100 speed: disabling TSO
eth0: no IPv6 routers present



**linux:/home/user1/Desktop # dmesg | grep eth0**
eth0: (PCI Express:2.5GB/s:Width x1) 00:1b:fc:5d:85:3e
eth0: Intel(R) PRO/1000 Network Connection
eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
eth0: 10/100 speed: disabling TSO
eth0: no IPv6 routers present


**linux:/home/user1/Desktop # ifconfig eth0 up**


**linux:/home/user1/Desktop # dmesg |grep eth0**
eth0: (PCI Express:2.5GB/s:Width x1) 00:1b:fc:5d:85:3e
eth0: Intel(R) PRO/1000 Network Connection
eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
eth0: 10/100 speed: disabling TSO
eth0: no IPv6 routers present


**linux:/home/user1/Desktop # cat /var/log/messages | grep e1000e**
Aug 20 00:26:22 linux kernel: e1000e: Unknown parameter `eeprom_bad_csum_allow'
Aug 20 00:35:46 linux kernel: e1000e: Intel(R) PRO/1000 Network Driver - 0.2.0
Aug 20 00:35:46 linux kernel: e1000e: Copyright (c) 1999-2007 Intel Corporation.


**linux:/home/user1/Desktop # rmmod e1000**
ERROR: Module e1000 does not exist in /proc/modules


**linux:/home/user1/Desktop # rmmod e1000e**


**linux:/home/user1/Desktop # modprobe e1000e eeprom_bad_csum_allow=0**
FATAL: Error inserting e1000e (/lib/modules/2.6.25.5-1.1-pae/kernel/drivers/net/e1000e/e1000e.ko): Unknown symbol in module, or unknown parameter (see dmesg)


**linux:/home/user1/Desktop # dmesg | grep eth[0-9]**
eth0: (PCI Express:2.5GB/s:Width x1) 00:1b:fc:5d:85:3e
eth0: Intel(R) PRO/1000 Network Connection
eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
eth0: 10/100 speed: disabling TSO
eth0: no IPv6 routers present


2nd RUN:



**linux:/home/user1/Desktop # dmesg | grep eth**
Parsing all Control Methods:
Table [DSDT](id 0001) - 701 Objects with 56 Devices 206 Methods 26 Regions
Parsing all Control Methods:
Table [SSDT](id 0002) - 9 Objects with 0 Devices 3 Methods 0 Regions
Parsing all Control Methods:
Table [SSDT](id 0003) - 7 Objects with 0 Devices 4 Methods 0 Regions
Initializing Device/Processor/Thermal objects by executing _INI methods:.
Executed 1 _INI methods requiring 0 _STA executions (examined 62 objects)
ACPI Error (psparse-0537): Method parse/execution failed \_PR_.CPU1._OSC] (Node dec32888), AE_ALREADY_EXISTS
ACPI: Marking method _OSC as Serialized
ACPI Error (psparse-0537): Method parse/execution failed \_PR_.CPU1._PDC] (Node dec3289c), AE_ALREADY_EXISTS
ACPI: Marking method _PDC as Serialized
ACPI Error (psparse-0537): Method parse/execution failed \_PR_.CPU2._OSC] (Node dec327d4), AE_ALREADY_EXISTS
ACPI: Marking method _OSC as Serialized
ACPI Error (psparse-0537): Method parse/execution failed \_PR_.CPU2._PDC] (Node dec327e8), AE_ALREADY_EXISTS
ACPI: Marking method _PDC as Serialized
Driver 'sd' needs updating - please use bus_type methods
eth0: (PCI Express:2.5GB/s:Width x1) 00:1b:fc:5d:85:3e
eth0: Intel(R) PRO/1000 Network Connection
eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
Driver 'sr' needs updating - please use bus_type methods
eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
eth0: 10/100 speed: disabling TSO
eth0: no IPv6 routers present


**linux:/home/user1/Desktop # dmesg | grep eth0**
eth0: (PCI Express:2.5GB/s:Width x1) 00:1b:fc:5d:85:3e
eth0: Intel(R) PRO/1000 Network Connection
eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
eth0: 10/100 speed: disabling TSO
eth0: no IPv6 routers present



**linux:/home/user1/Desktop # ifconfig eth0 up**
eth0: unknown interface: No such device


**linux:/home/user1/Desktop # ifconfig eth0 up**
eth0: unknown interface: No such device


**linux:/home/user1/Desktop # ifconfig eth0 up**
eth0: unknown interface: No such device



**linux:/home/user1/Desktop # dmesg |grep eth0**
eth0: (PCI Express:2.5GB/s:Width x1) 00:1b:fc:5d:85:3e
eth0: Intel(R) PRO/1000 Network Connection
eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
eth0: 10/100 speed: disabling TSO
eth0: no IPv6 routers present


**linux:/home/user1/Desktop # cat /var/log/messages | grep e1000e**
Aug 20 00:26:22 linux kernel: e1000e: Unknown parameter `eeprom_bad_csum_allow'
Aug 20 00:35:46 linux kernel: e1000e: Intel(R) PRO/1000 Network Driver - 0.2.0
Aug 20 00:35:46 linux kernel: e1000e: Copyright (c) 1999-2007 Intel Corporation.
Aug 21 18:49:41 linux kernel: e1000e: Unknown parameter `eeprom_bad_csum_allow'



**linux:/home/user1/Desktop # rmmod e1000**
ERROR: Module e1000 does not exist in /proc/modules


**linux:/home/user1/Desktop # rmmod e1000e**
ERROR: Module e1000e does not exist in /proc/modules


**linux:/home/user1/Desktop # modprobe e1000e eeprom_bad_csum_allow=0**
FATAL: Error inserting e1000e (/lib/modules/2.6.25.5-1.1-pae/kernel/drivers/net/e1000e/e1000e.ko): Unknown symbol in module, or unknown parameter (see dmesg)


**linux:/home/user1/Desktop # dmesg | grep eth[0-9]**
eth0: (PCI Express:2.5GB/s:Width x1) 00:1b:fc:5d:85:3e
eth0: Intel(R) PRO/1000 Network Connection
eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
eth0: 10/100 speed: disabling TSO
eth0: no IPv6 routers present

what is most striking is that the command

ifconfig eth0 up

once gives no error but after a matter of 10 minutes says

eth0: unknown interface: No such device

now can you guys please help me around…

On Thu, 21 Aug 2008 13:56:02 GMT
12345 <12345@no-mx.forums.opensuse.org> wrote:

> LINUX:/HOME/USER1/DESKTOP # DMESG | GREP ETH
> …
> eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
> eth0: 10/100 speed: disabling TSO
> eth0: no IPv6 routers present

System says it has a cable plugged in, and is ready at 100Base-T

> LINUX:/HOME/USER1/DESKTOP # DMESG | GREP ETH0
> …
> eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
> eth0: 10/100 speed: disabling TSO
> eth0: no IPv6 routers present

And again.

> LINUX:/HOME/USER1/DESKTOP # IFCONFIG ETH0 UP

This implies you haven’t set up the card yet in YaST Network Devices

> LINUX:/HOME/USER1/DESKTOP # DMESG |GREP ETH0
> …
> eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
> eth0: 10/100 speed: disabling TSO
> eth0: no IPv6 routers present

No, really, it’s ready and connected.

> LINUX:/HOME/USER1/DESKTOP # CAT /VAR/LOG/MESSAGES | GREP E1000E
> Aug 20 00:26:22 linux kernel: e1000e: Unknown parameter
> `eeprom_bad_csum_allow’ Aug 20 00:35:46 linux kernel: e1000e: Intel(R)

PRO/1000 Network Driver - 0.2.0 Aug 20 00:35:46 linux kernel: e1000e:
Copyright (c) 1999-2007 Intel Corporation.

Obviously, you’ve tried to tell it something it didn’t like.

LINUX:/HOME/USER1/DESKTOP # RMMOD E1000
ERROR: Module e1000 does not exist in /proc/modules

It’s not loaded… are you sure that’s the module name?

LINUX:/HOME/USER1/DESKTOP # RMMOD E1000E

Ah, that’s it.

LINUX:/HOME/USER1/DESKTOP # MODPROBE E1000E EEPROM_BAD_CSUM_ALLOW=0
FATAL: Error inserting e1000e
(/lib/modules/2.6.25.5-1.1-pae/kernel/drivers/net/e1000e/e1000e.ko):
Unknown symbol in module, or unknown parameter (see dmesg)

This usually comes from not running ‘depmod -a’ after installing a new
module, not rebooting, or an icky parameter. (I’m betting parameter)

LINUX:/HOME/USER1/DESKTOP # DMESG | GREP ETH[0-9]
eth0: (PCI Express:2.5GB/s:Width x1) 00:1b:fc:5d:85:3e
eth0: Intel(R) PRO/1000 Network Connection
eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
eth0: 10/100 speed: disabling TSO
eth0: no IPv6 routers present

It’s still there, hasn’t left. Still Connected and ready @ 100Mbps

2nd RUN:

Oh goody!

LINUX:/HOME/USER1/DESKTOP # DMESG | GREP ETH
eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
eth0: 10/100 speed: disabling TSO
eth0: no IPv6 routers present

Peek a boo!

LINUX:/HOME/USER1/DESKTOP # DMESG | GREP ETH0
eth0: (PCI Express:2.5GB/s:Width x1) 00:1b:fc:5d:85:3e
eth0: Intel(R) PRO/1000 Network Connection
eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
eth0: 10/100 speed: disabling TSO
eth0: no IPv6 routers present

Yes, you found it again.

LINUX:/HOME/USER1/DESKTOP # IFCONFIG ETH0 UP
eth0: unknown interface: No such device

It’s probably not configured in YaST Network Devices

LINUX:/HOME/USER1/DESKTOP # IFCONFIG ETH0 UP
eth0: unknown interface: No such device

It’s probably STILL not configured.

LINUX:/HOME/USER1/DESKTOP # IFCONFIG ETH0 UP
eth0: unknown interface: No such device

Sie sprechen Englisch?

LINUX:/HOME/USER1/DESKTOP # DMESG |GREP ETH0
eth0: (PCI Express:2.5GB/s:Width x1) 00:1b:fc:5d:85:3e
eth0: Intel(R) PRO/1000 Network Connection
eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
eth0: 10/100 speed: disabling TSO
eth0: no IPv6 routers present

Nothing changed here… move along…

LINUX:/HOME/USER1/DESKTOP # CAT /VAR/LOG/MESSAGES | GREP E1000E
Aug 20 00:26:22 linux kernel: e1000e: Unknown parameter
eeprom_bad_csum_allow' Aug 20 00:35:46 linux kernel: e1000e: Intel(R) &gt; PRO/1000 Network Driver - 0.2.0 Aug 20 00:35:46 linux kernel: e1000e: &gt; Copyright (c) 1999-2007 Intel Corporation. Aug 21 18:49:41 linux kernel: &gt; e1000e: Unknown parameter eeprom_bad_csum_allow’

Still have that bad parameter. Did you check in /etc/modprobe.d/
or /etc/modprobe.conf for an entry with that icky parameter in it?

> LINUX:/HOME/USER1/DESKTOP # RMMOD E1000
> ERROR: Module e1000 does not exist in /proc/modules

Nothing named ‘e1000’ here!

> LINUX:/HOME/USER1/DESKTOP # RMMOD E1000E
> ERROR: Module e1000e does not exist in /proc/modules

Nope, wasn’t loaded this time, icky parameter was given.

> LINUX:/HOME/USER1/DESKTOP # MODPROBE E1000E EEPROM_BAD_CSUM_ALLOW=0
> FATAL: Error inserting e1000e
> (/lib/modules/2.6.25.5-1.1-pae/kernel/drivers/net/e1000e/e1000e.ko):
> Unknown symbol in module, or unknown parameter (see dmesg)

Module symbols don’t match… or an icky parameter was given…

> LINUX:/HOME/USER1/DESKTOP # DMESG | GREP ETH[0-9]
> eth0: (PCI Express:2.5GB/s:Width x1) 00:1b:fc:5d:85:3e
> eth0: Intel(R) PRO/1000 Network Connection
> eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
> eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
> eth0: 10/100 speed: disabling TSO
> eth0: no IPv6 routers present

Nothing changed.

>
> what is most striking is that the command
> Code:
> --------------------
> ifconfig eth0 up
> --------------------
> once gives no error but after a matter of 10 minutes says
> Code:
> --------------------
> eth0: unknown interface: No such device
> --------------------

Computers get tired too.

> now can you guys please help me around…

Have you tried configuring the card in YaST Network Devices?

Loni


L R Nix
lornix@lornix.com
Funny, it just sits there…

This is like a network sitcom… :slight_smile: Looking forward to the next episode.

yeah i did try to … didn’t know any specific command so did try my luck by the ‘point and click’ method… still nothing seems to have changed …

and thank u so much for taking time to reply the way u did…

On Fri, 22 Aug 2008 12:16:01 GMT
12345 <12345@no-mx.forums.opensuse.org> wrote:

>
> lornix Wrote:
> >
> > Have you tried configuring the card in YaST Network Devices?
> >
>
>
> yeah i did try to … didn’t know any specific command so did try my
> luck by the ‘point and click’ method… still nothing seems to have
> changed …
>
> and thank u so much for taking time to reply the way u did…
>
>

Awww {Blush} You’re welcome!

In Yast -> Network Devices, click on ‘Network Settings’.

Now, if you click and select your network device, then click on ‘edit’ down
below, you can edit the parameters for it.

Once you’re there, you’ll see a few tabs and things, just make sure that the
selector has ‘DHCP’ selected in the middle of the three options there on the
upper left where it says “Dynamic Address”. Verify or change as needed, then
click on ‘Next’. You should be back at the ‘Network Settings’ screen you saw
before, now click on “Finish”.

It should whirr and click for a moment, then go through a little checklist as
it sets up things and enables your network.

Once it’s finished, assuming you have a relatively typical home user setup,
then you’ll be working great and online!

Loni


L R Nix
lornix@lornix.com
Click what?

i’ve done all that you’ve told above… but i’m still not able to connect on SUSE 11 :frowning:

On Fri, 22 Aug 2008 12:56:02 GMT
12345 <12345@no-mx.forums.opensuse.org> wrote:

>
> i’ve done all that you’ve told above… but i’m still not able to connect
> on SUSE 11 :frowning:
>
>

Does it say ‘dhcp’ next to the device in the Network Settings screen?

Have you rebooted your system to see if that helps any?

Loni


L R Nix
lornix@lornix.com

i’m assuming that u mean the DHCP as in this pic attached

http://img440.imageshack.us/img440/5863/screenshotie6.th.png](http://img440.imageshack.us/my.php?image=screenshotie6.png)

On Sun, 24 Aug 2008 18:16:01 GMT
12345 <12345@no-mx.forums.opensuse.org> wrote:

>
> i’m assuming that u mean the DHCP as in this pic attached
>
> ‘[image: http://img440.imageshack.us/img440/5863/screenshotie6.th.png]’
> (http://img440.imageshack.us/my.php?image=screenshotie6.png)
>
>

Yes, that’d be the one.

Brain’s not working real well lately, so I’m not really useful here. maybe
someone who knows something could help.

Sorry

Loni


L R Nix
lornix@lornix.com

or has it got to do something with firefox ??

some setting in firefox which i should configure { my connection is adsl and uses PPPOE } so is there any changes to be made in firefox ??

go to windows and reinstall the windows lan driver. boot to linux and reconfigure the network card. it worked for me after much drama.

How ?? can u please be a bit more specific …

and on SUSE…when i try to ping

ping en.wikipedia.org

it works fine…it gives out a list time taken etc…so i somehow doubt there is some other problem … such as with firefox…

do you have a dual boot with windows and suse?

Yes. XP and SUSE 11

things work fine on XP… but SUSE is giving problems

boot windows. go to gigabyte website and get latest lan driver for win xp and then install. takes 5 minutes. i would save lan driver. check windows internet. should still be there.

boot to suse. check internet. it probably still doesn’t work. start yast. select network devices in left pane. select network card in right pane. reconfigure the gigabyte lan card. internet might work.

Hi!

I have gigabit PC Pentium Extreme version 3.73 GHz with 4 GB RAM. I am also suffering problem with SUSE 11 for (a) gigabit card, (b)DSL setup.

However, I tackled the card problem as follows (in root mode):
(a)lsmod <enter> [to see the presence of e1000 or e1000e module],
(b) rmmod <module name whichever is presence like e1000 or e1000e>,
(c) modprobe e1000 to see whether it comes, IF NOT
(d) modprobe e1000e,
(e) depmod -a [to make dependencies of all modules],
(f)configured eth0 for gigabit card bu fixing IP,
(g)ifconfig eth0 up to keep up eth0.

That’s all.
ciao
Abhijit

both the above didn’t work…ping command works like a charm … Y???