problem with okular

After you install and uninstall kde4, okular shows me pdf in blank

How I can solve it?

Try deleting the hidden okular configs in .kde4

I already tried to delete the entire folder .kde4

Is it limited to a specific .pdf or are they all the same?
I have come across this before with certain .pdf’s

with all pdf alike

openSUSE version?

kde4 version? ( kde4-config -v )

opensuse 11.2
gnome 2.28

Before installing and uninstalling kde worked well

Herein lies your issue.
I expect you need to install the kde4-base system, maybe even more than that. Might it be not be easier to use Evince?

Evince is too simple for my taste.

Are you sure I should install the pattern kde4_base? Be installed dolphin and many other applications, okular worked before without all this

I’m using gnome to write this ATM. I just tried Evince and it looks fine, but I guess it lacks some features. You could always use the dreaded Adobe>:(

But I see no issue adding the kde-base pattern.

On my kde system I would be reluctant to add a Gnome pattern and loose the kde-pure system. But the two should work side by side. The issue with kde is mainly the Compiz thing. KDE does not need Compiz and some have tried adding Compiz to kde and it drags in most of gnome patterns with it.

Anyway, back to point. You should be fine having both desktops installed and using just gnome. I’m getting to like Gnome myself.

I have it solved, I figured it was because some kde libraries that are deleted when I remove kde.

Okular installed via 1-click-install and installed the necessary libraries, without having to install the kde pattern.

Grettings.

well done :slight_smile: