Problem with Okular displaying all text in a PDF

Okular is having problems displaying all of the text in some PDF files. For example, when displaying a Chase Bank credit card statement, the background images and logos are the only thing displayed (and all in the correct location on the page), but the regular text of my statement is all missing. I wish I could attach a screenshot, its strange. I tried messing with Okular’s setting, no luck. This bug is not present with most PDF files. I can use other applications to display the affected PDFs correctly, the problem is just with Okular.

I use OpenSUSE as a full home / office desktop, and have not had problems displaying any kind of PDF in Okular until recently. I cannot say for sure that the problem began with the recent upgrade to Leap 42.1, though I reproduced the problem on two Leap systems which were setup quite differently. It worked fine on 13.1, I did not test 13.2. It is possible Chase Bank changed the way they build PDFs at the time I upgraded to Leap and this bug “appeared”, though I found another file recently similarly having no text.

Probably caused by the outdated poppler in Leap (coming from SLE12).

An update is on the way and should be available on Monday or so, maybe this would fix it already.

I’m having the exact same issue with Chase Bank statements. Has this ever been resolved?

hi gnumattx,

the same has been encounter but from different sources

in many cases the text it there but masked by other things, eg. text boxes, graphics …

sometimes all can be revealed. Import the file into libreoffice-draw, putting the mouse pointer
over the affected area will highlight the offending article, which can then be moved or deleted
(there is sometimes more than one item doing the masking)

when edited the file can than be saved as a pdf file under a different name

the above does not work if the original pdf is in graphics format

an unnecessary drag