Problem with network configuration on OpensSuse 11.2 and KDE

I have installed opensuse 11.2 and I cant configure my wireless network.
I have used network configuration in YAST but I still dont have internet.
Previously I used in OPensuse 11.1 manual configuration into network configuration and it worked, but now it does not work anymore in 11.2
I’m using an USB wireless wich worked previously
Any idea how I must do the configuration in yast?
I’m newbie and I appreciatte if someone can help me

Please read this sticky Getting your wireless to work and this sticky My wireless doesn’t work - a primer on what I should do next and post back here some information to help us to help you.

I’m reading both. It appears to be OK my wireless adapter.
This is curious:
In GNOME i can use the network manager and I can connect with my wireless USB.
In KDE I can’t connect via network manager. It stops trying to accquire an IP address.

Anyway, In both cases using GNOME or KDE I can’t connect via IFUP

Here’s so far I accomplished in KDE using ifup

darthmikael@THX1151:~> sudo /usr/sbin/iwlist scan
lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wmaster0 Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:19:E4:D9:7D:81
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=66/70 Signal level=-44 dBm
Encryption key:on
ESSID:“INFINITUM7078”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s
Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=00000000f33501a7
Extra: Last beacon: 1381ms ago
IE: Unknown: 000D494E46494E4954554D37303738
IE: Unknown: 010882848B0C12961824
IE: Unknown: 030101
IE: Unknown: 0706555320010B1B
IE: Unknown: 2A0102
IE: Unknown: 32043048606C
Cell 02 - Address: 00:1B:5B:B8:6F:E1
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=36/70 Signal level=-74 dBm
Encryption key:on
ESSID:“INFINITUM2113”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s
Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=000000012d919181
Extra: Last beacon: 1040ms ago
IE: Unknown: 000D494E46494E4954554D32313133
IE: Unknown: 010882848B960C121824
IE: Unknown: 030106
IE: Unknown: 050400010000
IE: Unknown: 0706555320010B1B
IE: Unknown: 2A0100
IE: Unknown: 32043048606C

eth1 Interface doesn’t support scanning.

darthmikael@THX1151:~> sudo /usr/sbin/iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:“INFINITUM7078”
Mode:Managed Frequency:2.412 GHz Access Point: 00:19:E4:D9:7D:81
Bit Rate=48 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:E4A3-9323-CCE2-1E39-FA48-66BA-E4
Power Management:on
Link Quality=64/70 Signal level=-46 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth1 no wireless extensions.

darthmikael@THX1151:~> sudo /usr/sbin/ifconfig
sudo: /usr/sbin/ifconfig: command not found
darthmikael@THX1151:~> sudo /usr/sbin/iwlist scan
lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wmaster0 Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:19:E4:D9:7D:81
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=63/70 Signal level=-47 dBm
Encryption key:on
ESSID:“INFINITUM7078”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s
Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=000000010ee257e2
Extra: Last beacon: 1379ms ago
IE: Unknown: 000D494E46494E4954554D37303738
IE: Unknown: 010882848B0C12961824
IE: Unknown: 030101
IE: Unknown: 0706555320010B1B
IE: Unknown: 2A0100
IE: Unknown: 32043048606C

eth1 Interface doesn’t support scanning.

darthmikael@THX1151:~> sudo /usr/sbin/iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:“INFINITUM7078”
Mode:Managed Frequency:2.412 GHz Access Point: 00:19:E4:D9:7D:81
Bit Rate=48 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:E4A3-9323-CCE2-1E39-FA48-66BA-E4
Power Management:on
Link Quality=63/70 Signal level=-47 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth1 no wireless extensions.

darthmikael@THX1151:~> ping -c 5 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.112: icmp_seq=2 Destination Host Unreachable
From 192.168.1.112 icmp_seq=2 Destination Host Unreachable
From 192.168.1.112 icmp_seq=3 Destination Host Unreachable
From 192.168.1.112 icmp_seq=4 Destination Host Unreachable
From 192.168.1.112 icmp_seq=5 Destination Host Unreachable

— 192.168.1.1 ping statistics —
5 packets transmitted, 0 received, +5 errors, 100% packet loss, time 4000ms
, pipe 3
darthmikael@THX1151:~> ping -c 5 66.70.73.150
PING 66.70.73.150 (66.70.73.150) 56(84) bytes of data.
From 192.168.1.112: icmp_seq=2 Destination Host Unreachable
From 192.168.1.112 icmp_seq=2 Destination Host Unreachable
From 192.168.1.112 icmp_seq=3 Destination Host Unreachable
From 192.168.1.112 icmp_seq=4 Destination Host Unreachable
From 192.168.1.112 icmp_seq=5 Destination Host Unreachable

— 66.70.73.150 ping statistics —
5 packets transmitted, 0 received, +5 errors, 100% packet loss, time 4001ms
, pipe 3
darthmikael@THX1151:~> /sbin/ifconfig
eth1 Link encap:Ethernet HWaddr 00:04:4B:17:B6:10
inet addr:192.168.1.112 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:27 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:119 errors:0 dropped:0 overruns:0 frame:0
TX packets:119 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:9431 (9.2 Kb) TX bytes:9431 (9.2 Kb)

wlan0 Link encap:Ethernet HWaddr 00:06:F4:0A:55:77
inet6 addr: fe80::206:f4ff:fe0a:5577/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:172 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:60336 (58.9 Kb)

wmaster0 Link encap:UNSPEC HWaddr 00-06-F4-0A-55-77-00-00-00-00-00-00-00-00-00-00
UP RUNNING MTU:0 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

darthmikael@THX1151:~>

In KDE networkmanager, go to “Manage Connections”, choose the wireless network in question, choose “Edit”, choose “IP Address” tab, set the Combo Box value to “Routes”, uncheck both “Automatically obtained routes” and “Use only for resources on this connection”.
Save it. Logout of KDE and then log in.
Now, try the wireless connection.

Just some drive-by comments:

Good luck with syampillai’s method

I have a similar problem. With KDE 4.3.x I can connect to unsecured WLAN’s but not to secured, it doesn’t even try. But if I login with Gnome, secured wireless works flawlessly. Will KDE be fixed soon?

It’s been the same story for me with 10.2, 10.3, 11.0, 11.1 and 11.2, so I can’t answer that question calmly. Perhaps a calm person will reply.

On 11/30/2009 10:46 PM, swerdna wrote:
>
> Gothmaniac;2079368 Wrote:
>> I have a similar problem. With KDE 4.3.x I can connect to unsecured
>> WLAN’s but not to secured, it doesn’t even try. But if I login with
>> Gnome, secured wireless works flawlessly. Will KDE be fixed soon?
>
> It’s been the same story for me with 10.2, 10.3, 11.0, 11.1 and 11.2,
> so I can’t answer that question calmly. Perhaps a calm person will
> reply.

Both KDE and Gnome work for me with unsecured, WEP, WPA AND WPA2
networks using either NetworkManager or ifup. I tested very thoroughly
after WPA2 did not work with M7. It was fixed in M8 and continued to
work with RC1, RC2 and GM.

You need to use the “Manage Connections” option from the applet and edit
your connection. In fact you may be better off by deleting the existing
connection and remaking it. If you get a popup asking for the secret, it
will not work as that secret is not passed to NM nor to the wallet for
keeping.

I have the same problem. Network Manager in KDE is broken.
Without NM (meaning ifup) everything works fine, NM have a problem with authentication for any type of security (WEP, WPA…) enabled.
Do anybody have explanation of that?

Przemek

On 12/15/2009 07:56 PM, Pemekcz wrote:
>
> I have the same problem. Network Manager in KDE is broken.
> Without NM (meaning ifup) everything works fine, NM have a problem with
> authentication for any type of security (WEP, WPA…) enabled.
> Do anybody have explanation of that?

There were bugs in the released versions. Those have been fixed.
Update your system and it should work. Please delete your old
connection and make a new one.

I can confirm that. I have installed Kde 4.3.4 instead of initial 4.3.1 and NM started working again.

I can confirm that the standard online updates are all that was necessary to fix NM for me. I didn’t need to update KDE, just apply the standard updates and delete the old connection and re-create it again from scratch as recommend by lwfinger

Great thing… I was using “wvdial” for my USB modem connection. Could not use Kinternet also as it requires kdelibs3 which screws up the system.

But I will try NM again and see… :slight_smile: