Problem with mysql-community-server

I tried to move mysql data folder in home folder.
After rebooting get the following error

rcmysql start
Starting service MySQL warning: /var/run/mysql/mysql.sock didn't appear within 30 seconds
chmod: cannot access `/var/run/mysql/mysqld.pid': No such file or directory

I tried to return things, reinstall mysql-community-server, remove /var/lib/mysql but to no avail, the same mistake again

rcmysql start
Starting service MySQL warning: /var/run/mysql/mysql.sock didn't appear within 30 seconds
chmod: cannot access `/var/run/mysql/mysqld.pid': No such file or directory

Can you give me a hand?

The answer is not to try and change the mysql installation or mess with the folders. Leave everything where it is; enable mysqld (in YaST>System services) and periodically backeverything up to /home with something like:
mysqldump -u root -p -F -master-data=2 -A -delete-master-logs > Filename.sql
You will first need to su – to root and, when you have issued the command, give the mysql root password. As long as Filename.sql is on /home, you will then have a backup of your entire data (including passwords) on /home.

To restore this after a fresh installation of mysql enter these as the first commands after logging into mysql without a password
source Filename.sql
flush privileges;

It is worth reading the section in info mysql about backing up and restoring.

john hudson wrote:
> The answer is not to try and change the mysql installation or mess with
> the folders. Leave everything where it is

Well that’s certainly the simplest solution if it meets the
requirements. But its quite easy to have multiple instances of the mysql
server running on a single host with all the data files in different
directories. The manual has a whole chapter on how to do it in various
circumstances. E.g.
http://dev.mysql.com/doc/refman/5.0/en/multiple-servers.html

To the OP: you need to start the server with the appropriate options. On
my systems, I find the easiest way is to have a separate configuration
file for each instance and then to start each server with a command-line
option specifying the correct configuration file. You also need to start
clients with the same command-line option.

It sounds like you have not started your server with an option (on the
command-line or in the config file) specifying consistent locations of
the data and the socket. Reread the manual and check all the file paths.

If you’re still having trouble, come back here and post:
(1) the contents of your config file
(2) the command-line you use to start the server
(3) the output of ‘ls -l’ on every directory mentioned in either place

HTH, Dave