Problem with my video/display/graphics card

My system is fully updated and when I ran VLC it would not show the visual portion of videos just the sound. Then it would freeze up and render my system unusable until I was forced to restart. I thought it was the player itself but the same thing happened with the native Kaffeine player so I know that’s not the issue. Help would be greatly appreciated. I’m running the latest version of opensuse 13.2.

Post info from

su 
hwinfo --gfxcard

Here it is.

linux-gu7v:/home/David # hwinfo --gfxcard09: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.328]
  Unique ID: _Znp.lf53H7HNsb8
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel VGA compatible controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x1616 
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x2336 
  Revision: 0x09
  Driver: "i915"
  Driver Modules: "drm"
  Memory Range: 0xc1000000-0xc1ffffff (rw,non-prefetchable)
  Memory Range: 0xb0000000-0xbfffffff (ro,non-prefetchable)
  I/O Ports: 0x6000-0x603f (rw)
  IRQ: 60 (30284 events)
  Module Alias: "pci:v00008086d00001616sv0000103Csd00002336bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown



And also could you help me see what driver, if any, I have for my webcam? Its an HP Laptop so its built in but I’m not sure if I have a driver at all or the right and updated one. I’m trying to use it for video calls on Skype. But when I loaded it up all I saw was black.

Try to uninstall the package libvdpau_va_gl1:

sudo zypper rm libvdpau_va_gl1

The latest VLC version apparently has problems on some systems when it is installed.

Background: VDPAU is NVidia’s hardware video decoding, while intel only supports VA-API (something similar, but not the same).
To use VDPAU with intel, you need that package (it “emulates” VDPAU via VA-API), that’s why it is installed by default on intel systems.
But apparently it doesn’t support all functions yet.

VLC does support VA-API directly anyway, so you will not lose anything by removing that package.

This is likely best requested in a separate thread.

This simply could be Skype not having the correct dependencies loaded.

The openSUSE wiki page on webcams gives good guidance: https://en.opensuse.org/HCL:Web_cameras

Further, note webcam drivers are nominally included with the kernel, and so you should already have the driver installed. Many webcams are “uvc” compatible, and hence use a generic uvc driver. wrt helping you to see what driver, my understanding is HP have different types of webcams in their laptops, dependant on the make of laptop. Hence more information would be needed to be provided for users to advise what type of webcam you have ?

Hence in any new post, I recommend you list the name/make of your HP laptop, and also provide the output of sending the command in a konsole/xterm:


lsusb

for example, for my Toshiba laptop if I send ‘lsusb’ I obtain:


Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
**Bus 001 Device 003: ID 04f2:b369 Chicony Electronics Co., Ltd **
Bus 001 Device 004: ID 8087:07da Intel Corp. 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

where “ID 04f2:b369 Chicony Electronics Co., Ltd” is my webcam.

If I go to the list of uvc suported devices I will not see my 04f2:b369 listed as a UVC supported web cam. However that is not the be-all and end-all wrt UVC support.

With my also knowing that the majority (but not all) of webcams are uvc compatible, if I go to the Linux uvc page I obtain an instruction to send the command (now tuned for my webcam):


lsusb -d 04f2:b369 -v | grep "14 Video"

and I obtain :


linux-0w6l:/home/oldcpu # lsusb -d 04f2:b369 -v | grep "14 Video"
      bFunctionClass         14 Video
      bInterfaceClass        14 Video
      bInterfaceClass        14 Video
      bInterfaceClass        14 Video
      bInterfaceClass        14 Video
      bInterfaceClass        14 Video
      bInterfaceClass        14 Video
      bInterfaceClass        14 Video
      bInterfaceClass        14 Video
      bInterfaceClass        14 Video

which confirms my webcam should be uvc compatible (because If there were no such lines, my device would not be a UVC device. ) .

Hence my webcam ‘just works’.

I don’t really see a problem there

I uninstalled that package and it all went fine. Until I tried to play a video again and the same thing happened. Sound and just a black screen inside the window, then freezing up until I had to push the power button to turn it off and restart. The same thing happens when I try to use Skype or any video player. So I’m sure its some issue with that.

Did you reboot??

Okay scratch that. VLC works fine now but it has some green dots on the screen? Like its an old laptop that I have or something. Anyway to fix that? Its the native Kaffeine player that’s still messing up now. Is there a package I need to remove to make that work as well? Thanks for all your help guys I really appreciate it.

Yes I did but see the previous post. I have a minor new issue, sadly. But it’s not super huge.

This really sounds like a video card/driver issue. Exactly what driver are you using. Fast way to check is to open kinfocenter.

Do you have a /etc/X11/xorg.conf file? if so rename it. Should not be needed

Its a fluke the issue is still there. Whether I play with VLC or Kaffeine or any other the video plays fine on VLC at first then starts getting dodgy and freezes up my system so I have to do s force restart. So many issues with this distro maybe I should try another one.

Maybe but most people don’t have the problems you see. In fact you appear unique in this particular problem.

Where do I look for this file? And I opened kinfocenter under graphics and found an OpenGL category that lists the graphics card. Is that the same as the video display card? I’m not sure.

yes should also not the driver

the /etc/X11/xorg.conf file is that. ie I gave full path to the file

Note you will need to be root to rename it if it exist. if it does not then just tell us so.

Terminal says no such file or directory found so no its not there.

And when I just woke my laptop up from sleep the monitor wouldn’t come on. I had to restart then it did.

Can I get some help with this? Its the last issue I’m currently having with opensuse and would put my mind at ease so I can start seeing what this OS can do.

Is it the back light that does not come on?