Problem with microphone - OpenSUSE 11.3

Hi.
I’m having Dell T1500 with SB 1040, and no luck with microphone working (yes microphone is checked and its working).
Some data that i read are needed.

user@arksuse:~> rpm -qa '*alsa*'
alsa-1.0.23-2.12.x86_64
alsa-oss-32bit-1.0.17-29.2.x86_64
alsa-devel-1.0.23-2.12.x86_64
alsa-utils-1.0.23-1.8.x86_64
alsa-plugins-32bit-1.0.23-1.9.x86_64
alsa-oss-1.0.17-29.2.x86_64
alsa-plugins-1.0.23-1.9.x86_64


user@arksuse:~> rpm -qa '*pulse*'
libpulse0-0.9.21-10.3.1.x86_64
libpulse-mainloop-glib0-0.9.21-10.3.1.x86_64
libxine1-pulse-1.1.19-2.pm.45.45.x86_64
libmpg123-0-pulse-1.13.0-1.pm.1.1.x86_64

user@arksuse:~> rpm -q libsound2
pakiet libsound2 nie jest zainstalowany

user@arksuse:~> uname -a
Linux arksuse 2.6.34.10-0.2-desktop #1 SMP PREEMPT 2011-07-20 18:48:56 +0200 x86_64 x86_64 x86_64 GNU/Linux

user@arksuse:~> cat /etc/modprobe.d/50-sound.conf


options snd slots=snd-hda-intel
# YmUS.YhraNp3EzIA:SB1040
alias snd-card-0 snd-hda-intel

user@arksuse:~> arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Creative [HDA Creative], device 0: CA0110 Analog [CA0110 Analog]
  Subdevices: 2/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
card 0: Creative [HDA Creative], device 1: CA0110 Digital [CA0110 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

user@arksuse:~> arecord -L
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=Creative
    HDA Creative, CA0110 Analog
    Default Audio Device
front:CARD=Creative,DEV=0
    HDA Creative, CA0110 Analog
    Front speakers
surround40:CARD=Creative,DEV=0
    HDA Creative, CA0110 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Creative,DEV=0
    HDA Creative, CA0110 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Creative,DEV=0
    HDA Creative, CA0110 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Creative,DEV=0
    HDA Creative, CA0110 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Creative,DEV=0
    HDA Creative, CA0110 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Creative,DEV=0
    HDA Creative, CA0110 Digital
    IEC958 (S/PDIF) Digital Audio Output

file from alsa-info.sh http://margoteria.pl/suse/alsa-info.txt

I think i tried everything, but my knowledge about Linux systems isn’t solid. So if anyone could help me to get my mic working, so for example i could record with arecord it would be great.

Thanks for any help.

Arek

BTW. I hope i write this post in proper place, if not i’m sorry.

Hello apiekarski,

Welcome here.

The place you posted this (Multimedia) is good enough :wink:

Are you aware of thh fact that 11.3 is not supported anymore? That means not only that you do not get any more security updates, but also that not very many people here have 11.3 running. Thus it may be difficult to reproduce your problem. Or for people to think “How was that working in 11.3?”

Current openSUSE versions are 11.4 and 12.1.

Yep, i’m aware.

The problem is on my enterprise pc, and i’m a little affraid to upgrade. Cause if somethink goes wrong, i don’t have time to reinstall my pc.
Back to the problem. From my point of view everything looks ok, beside my mic doesn’t work. I see mic channel in kmix. It’s checked to capture. I tried front and back socket.
I feel helpless.

If someone be so nice and help me with this, i would really appreciate it.

Arek

thats the wrong command. The command should read:


rpm -q libasound2

ie you are missing the ‘a’. I think ‘a’ stands for ‘alsa’ in this case.

so your record devices are hw:0,0 (the analog) and hw:0,1 (the digital). Which one are you trying to use?

Thanks for script output link. I note this in mixer:


**!!Amixer output**
!!-------------

!!-------Mixer controls for card 0 [Creative]
**Simple mixer control 'Line',0
**  Front Left: Capture 115 [100%] [6.00dB] **[off]**
  Front Right: Capture 115 [100%] [6.00dB] **[off]**

ok, line mixer is OFF, but capture is jacked up to 100%. Why ? Thats inconsistent. Are you trying to capture with line ? If so, why have muted ?


**Simple mixer control 'Mic',0**
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 127
  Front Left: Capture 127 [100%] [12.00dB] [off]
  Front Right: Capture 127 [100%] [12.00dB] [off]

same comment. The Mic is muted but capture is jacked up to 100%. Why ? That’s inconsistent. Are you trying to capture with Mic (I assume yes)? If so you need to unmute it.


**Simple mixer control 'IEC958',0**
  Capture channels: Front Left - Front Right
  Front Left: Capture 115 [100%] [6.00dB] [off]
  Front Right: Capture 115 [100%] [6.00dB] [off]

This appears to be a digital Mic control ? < unsure > Again, same comment. The IEC958 capture is muted but capture is jacked up to 100%. Why ? That’s inconsistent. Are you trying to capture with IEC958 ? My guess is no, but I don’t know.


**Simple mixer control 'Digital',0**
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 120 [100%] [30.00dB]
  Front Right: Capture 120 [100%] [30.00dB]

Ok, thats the digital mic … hw:0,1 . Does it not capture ? What test did you do to test it ?

How about something like:


arecord -vv -f S16_LE -c 2 -D hw:0,1 new.wav

to record to file new.wav. Stop the recording by pressing <ctrl><c>

Check out those mixer settings I noted and fix them.

Thanks for you help oldcpu :slight_smile:

Chanels in kmix where off cause in my state i tried everything. Normally i leave them on, 1 of them, 2 of them, all of them.

I think Digital is only for output not as digital input, but i can be wrong.

As for libasound2, probably my retype mistake.

user@arksuse:~> rpm -q libasound2
libasound2-1.0.23-2.12.x86_64

I tried arecord with magic parameters :wink: and i get :frowning:

user@arksuse:~> arecord -vv -f S16_LE -c 2 -D hw:0,1 new.wav
Recording WAVE 'new.wav' : Signed 16 bit Little Endian, Rate 8000 Hz, Stereo
Warning: rate is not accurate (requested = 8000Hz, got = 44100Hz)
         please, try the plug plugin 
Hardware PCM card 0 'HDA Creative' device 1 subdevice 0
Its setup is:
  stream       : CAPTURE
  access       : RW_INTERLEAVED
  format       : S16_LE
  subformat    : STD
  channels     : 2
  rate         : 44100
  exact rate   : 44100 (44100/1)
  msbits       : 16
  buffer_size  : 16384
  period_size  : 4096
  period_time  : 92879
  tstamp_mode  : NONE
  period_step  : 1
  avail_min    : 4096
  period_event : 0
  start_threshold  : 1
  stop_threshold   : 16384
  silence_threshold: 0
  silence_size : 0
  boundary     : 4611686018427387904
  appl_ptr     : 0
  hw_ptr       : 0
arecord: pcm_read:1692: read error: Błąd wejścia/wyjścia

Last sentences stand for “arecord: pcm_read:1692: read error: Input/output error”

So i tried with hw:0,0 and got no error, but no sound with aplay too :frowning:

I’m lost, and helpless.

I can’t see your mixer settings, so I can not tell if you set them correctly after my caution in the previous post.

I do note this:



!!PCI Soundcards installed in the system !!--------------------------------------  03:00.0 PCI bridge: Creative Labs [SB X-Fi Xtreme Audio] CA0110-IBG PCI to PCIe Bridge 04:00.0 Audio device: Creative Labs [SB X-Fi Xtreme Audio] CA0110-IBG

where Creative Labs SB X-Fi Xtreme support has always been pathetic for GNU/Linux. I recall that some source code was passed to the GNU/Linux community, but even then to get it working was a bit of a hack. Whether that is related to your reported problem I can not say. Whether more recent GNU/Linux versions have addressed in a superior manner the poor X-Fi support that existed previous, I also can not say.