Problem with Linksys network card

I’ve trying to connect to wireless network with no luck. I have a 64bit HP desktop with a wireless card “Linksys Wireless-G PCI Adapter (WMP54G)”

The output of the command dmesg | less showed a lot of firmware issues so I installed NDISwrapper, I installed the XP drive (i actually tried two different) with no luck.

Here is the output of some commands


03:08.0 Network controller: RaLink RT2561/RT61 802.11g PCI
Subsystem: Linksys WMP54G ver 4.1
Flags: bus master, slow devsel, latency 32, IRQ 16
Memory at fddf0000 (32-bit, non-prefetchable) [size=32]
Capabilities: <access denied>
Kernel driver in use: rt61pci
Kernel modules: rt61pci

At this point I wonder if <access denied> has something to do with my problem.

/bin/lspci -n

03:08.0 0280: 1814:0301

After installing NDISwrapper and the driver, the firware messages were gone!

dmesg | less

ACPI: PCI Interrupt 0000:03:08.0[A] -> Link [APC1] -> GSI 16 (level, low) -> IRQ 16
phy0: Selected rate control algorithm ‘pid’
Adding 2104472k swap on /dev/sda1. Priority:-1 extents:1 across:2104472k


lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:""
Mode:Managed Channel:0 Access Point: Not-Associated
Tx-Power=0 dBm
Retry min limit:7 RTS thr: off Fragment thr=2352 B
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

At the bottom left of the screen, there are two PCs with a red X on it, if I right click “wireless networks” appears shaded out so I tried /usr/sbin/iwlist scan and…

lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wmaster0 Interface doesn’t support scanning.

wlan0 Interface doesn’t support scanning : Network is down

My network card is activated “at boot”, but it doesn’t show up in YaST under Hardware of Network Services. So far I can only think of: the card is not supported yet by kernel, there is some kind of problem with the 64bit version o there is another firmware problem.[/size]

OK, I see my card under Yast → network devices → network settings. Once here it asked me:

“There is NDISwrapper configuration detected but the Kernel module was not modprobed. Do you what to modprobe ndiswrapper?”

I click yes, but, at some point it tries to connect to the internet, to the opensuse website, but of course, it can’t…

Any suggestions?

You dont need ndswrapper for a linksys card. I got mine working by just downloading the firmware from with yast. Then reboot and it should work.

wmp54gs - openSUSE Forums

Thanks for the suggestion Jaybott, but it didn’t work. Even though both cards are Linksys, the controller in your card is “Broadcom BCM4318” while mine is “RaLink RT2561/RT61” :sarcastic:. I went to the website of RaLink and I downloaded the firmware for linux for my controller, but after hours “googleing” and looking thru the help in my Opensuse 11, I have absolutely no clue how to install it on my computer. I will keep looking anyways… suggestions welcome!

Usually, the firmware file or files is copied into /lib/firmware. You
should be able to determine what files the driver needs by looking at
the output of the command dmesg.


Thank so much! My wireless network works and I’m able to connect to the internet!! yay!! Just in case somebody run into the same problem here is the link with the firmware Ralink Technology: Linux Note that this firmware was released after Opensuse 11, so it wasn’t included in this version.

I’m glad it works.


do you feel able to spell out in a 1. and 2. and 3. format what you did, as a track for others to follow coming after you?

Of course I can pdc_2,

1.- I tried to connect to the wireless network, on the bottom left of the computer there was an icon with two computer and a red X, I left click it and “wireless networks” appeared shaded, so I tried to scan manually using “/usr/sbin/iwlist scan” and I got “wlan0 Interface doesn’t support scanning : Network is down”.

2.- I did a “/sbin/lspci” and I got the network controller model as shown on the first post of this thread. The “dmesg | less” gave me lots of firmware messages. At this point I rolled my sleeves up :stuck_out_tongue:

3.- After checking here HCL/Network Adapters (Wireless - openSUSE) , I installed NDISwrapper from YaST, copied the driver from the cd that came with the wireless card and install it, it didn’t work but the firmware messages from “dmesg | less” were gone. I went to network devices, tried to edit the wireless card and I got a message that the firmware was missing. I googled RaLink and luckily “Ralink is very active in the Linux community, and provides source code for many of its client drivers to developers” as it says on their website, so I’m very happy I got this card. So here Ralink Technology: Linux I found the my network controller (RaLink RT2561/RT61), I downloaded the firmware and I just paste it into “/lib/firmware”, rebooted and… I worked!!

I hope this can help, and never give up!