Problem with LG 23" monitor

Hi, I just installed openSuSE 11.2
I choose this distro because it was supposed to be easier to set up dual monitor. But in the display settings, I can’t find my monitor. I have tried installing NVidia driver, but I get an error message that I don’t have GCC installed, or that cc is not in my path. I’m not sure if I need to install the driver or if the problem is something else. I have a laptop with a GForce GO 7600 video card.


I’m not really an expert on that (I have a problem seting up multiple desktops…) but, have you tried setting it up from SaX2?

Sounds like you’re trying to install the nVidia driver manually - which is the wrong way.

You should instead do it “the right way” and read here; NVIDIA - openSUSE

Thanks for your advice, I finally manage to install the driver. I can’t seem to run SaX though. When I try to start it, either from the command line or from the GUI, I’m being sent to run level 3. Is this normal? If yes, what am I supposed to do next?

Thank you

Not really a good idea in oS11.2 as sax2 will create a xorg.conf file that is not necessary anymore (unless you have specific hardware issues that require manual configuration, IMO). That’s why sax2 is not included by default in Yast2 anymore.

I’d try to correctly install the NVidia driver as posted above by Chrysantine and then activate the twinview option in NVidia’s control center. It worked for me in oS11.0 and 11.1, not sure about oS11.2 however.

By the way, if I go on the Hardware Information panel, my monitor is there.

I also forgot to mention I’m currently using a DVI plug


Thanks a lot. I just realized my orginal question wasn’t exactly right. Actually, I want to use only the the other monitor. I tried activating "separate x screen, but it dosen’t work. I get the following error:

The current settings cannot be completely applied due to one or more of the follwing reasons:

  • The location of an X screen has changed
  • The location type of an X screen has changed.
  • The color depth of an X screen has changed
  • An X screen has been added or removed
  • Xinerama is being enabled/disabled

For all the requested setting to take effect, you must save the configuration the X config file and restart X server

Where is the X configuration file. I must create it, or it exists somewhere?

By the way, it works in twin mode, so I know my monitor can work.

Thanks again

Assuming the NVIDIA driver is now correctly installed, run nvidia-settings as root and it will save whatever changes you make to xorg.conf.
Don’t use sax2 with dual monotors, at least not with NVIDIA cards. Has never worked in my experience.
If you’re still having problems after using nvidia-settings in this way, post your xorg.conf here.

Thanks a lot everybody. Everything’s working fine now! :slight_smile: