Problem with keyboard layout


I have Suse Enterprise 11

Sounds easy, but don’t know how to solve: If I set my keyboard layout in “Computer → YaST → Keyboardlayout” then I can chose the correct layout and it works fine. As soon as I restart the computer the layout-setting is lost and I have my old (and wrong) keyboard layout. The point is that I say “Save settings” (or however it is called in the english version, I have the german) after quitting SAX2…

The strange thing is also, that if I enter the conf. manager for keyboard layout and I enter some things in the testfield, the keyboardsettings are correct there… But in the terminal for example, I have the wrong settings…?

How can I make sure that my keyboard layout really get stored???

Thanks for every hint!

For Enterprise you should go here:
SUSE Linux Enterprise Desktop (SLED) - NOVELL FORUMS

or here:
SUSE Linux Enterprise Server (SLES) - NOVELL FORUMS