Problem with keyboard after adding joystick to xorg.conf

I have openSuSE 11.0 x86_64 and joystick Saitek x45. It works perfectly with games. “jstest /dev/input/js0” shows all axes and buttons.

But when I added to xorg.conf:


Section "ServerLayout"
   ...
   InputDevice  "Joystick[0]" "SendCoreEvents"
EndSection

Section "InputDevice"
    Identifier "Joystick[0]"
    Driver "joystick"
    Option "Device" "/dev/input/js0"
    Option "StartKeysEnabled" "False"
EndSection

my keyboards function keys (F1-F12) started to behave oddly.
I cannot change virtual terminal by pressing ctrl+alt+Fkey.
Pressing F10 behaves like pressing right mouse button.
I cannot reset Xorg by pressing ctrl+alt+backspace twice.
(but i can change my desktops by pressing ctrl+alt+left or right arrow)

I tried to search google, but haven’t found anything.
Thanks for any help.

etamPL wrote:

>
> I have openSuSE 11.0 x86_64 and joystick Saitek x45. It works
> perfectly with games. “jstest /dev/input/js0” shows all axes and
> buttons.
>
> But when I added to xorg.conf:
>
> Code:
> --------------------
>
> Section “ServerLayout”
> …
> InputDevice “Joystick[0]” “SendCoreEvents”
> EndSection
>
> Section “InputDevice”
> Identifier “Joystick[0]”
> Driver “joystick”
> Option “Device” “/dev/input/js0”
> Option “StartKeysEnabled” “False”
> EndSection
>
> --------------------
>
> my keyboards function keys (F1-F12) started to behave oddly.
> I cannot change virtual terminal by pressing ctrl+alt+Fkey.
> Pressing F10 behaves like pressing right mouse button.
> I cannot reset Xorg by pressing ctrl+alt+backspace twice.
> (but i can change my desktops by pressing ctrl+alt+left or right
> arrow)
>
> I tried to search google, but haven’t found anything.
> Thanks for any help.
>
>

IIRC after you use the joystick config dialogue from the “Configure Desktop” you do not need anything in the Xorg.conf, just comment out your lines and restart X ( logout and login ) and test the joystick and keyboard again.

At least that what happens here, there is NO entry for joystick in Xorg.conf needed.

HTH


Mark…

Nil illegitimi carborundum

I can’t find any “Configure Desktop”. I found, that there is such thing in KDE, but I’m using Gnome.

etamPL wrote:

>
> I can’t find any “Configure Desktop”. I found, that there is such
> thing in KDE, but I’m using Gnome.
>
>

Ag, you have me there then ( KDE only here, co not use Gnome at all ) however there is a package that is the wrapper and calibrator:

libjsw-calibrator - UNIX Joystick Driver Wrapper Library - Calibrator

Not sure but that might do.

HTH


Mark…

Nil illegitimi carborundum

This is only a calibration tool.

I found that there is QJoyPad for KDE. I can’t test it now, so I’ll write if it helps.

As a matter of fact, i currently use qjoypad in gnome SLED to use my usb-joystick. Otherwise, i would not be able to use it in most linux games.

<OF>