problem with kde konsole and home/end when line has >26 chars

Leap 15.2 x86_64
So, somewhere I must have f’d up royally and now konsole has a weird issue. If I type a command line that has more than 28 characters in it then the home key only goes back to character #18 and the end key now goes out to about 18 beyond the end where it should stop. If I could even just get the name of the file that might cause this issue i could probably fix it, but as of now I have no idea whats causing it.

The only files I can find within the configuration directories in my home directory that start with “konsole” are:


Maybe you can delete the first one and see if it helps. I assume it will be re-created with default values when you start konsole after that.

Does the same thing happen outside of konsole, try one of the virtual terminals, ctrl-alt-f2 for example. AFAIK there’s no setting within konsole that would present the issue you have, but, who knows…

Agree this should be first thing to check…
All openSUSE installs regardless of Desktop also install Xterm in an unenhanced, unmodified configuration. Its behavior should be the base functionality you should expect without any customizations. I’d expect that if you see the same behavior in xterm, your problem is not specific to konsole.

Konsole is the “enhanced” console installed with KDE.
AFAIK customizations should be found in the konsolerc file which is mentioned in this thread.

I don’t know if you’ll find additional useful info in the KDE handbook


Wow! I solved it! Its the PS1 variable.
i am going to explain it here for anyone who happens to get the same issue.

if you customize it you need to add \ and ] around ANY of your escape sequences except the built in stuff like \h \w etc

This is wrong:
[size=3]export PS1="\e[1m\e[1;36m\h:\w\e[0m $ "
This is correct:
export PS1="\\e[1m\]\\e[1;36m\]\h:\w\\e[0m\] $ "

I hope this helps someone, I was on the verge of reformatting my systems - its that aggravating when it is broken! Not only do the home and end keys not work correctly, the line wraps incorrectly also, so up-arrow produces a jumble of text.[/size]