Problem with Intel STAC92xx on HP Pavilion dv 4 laptop

Hi all,
I am not getting any sound on my HP Pavilion dv4 laptop. I read some of the previous threads and it seems that others have seen the same issue with Intel STAC92xx. But as the moderator pointed out, two machines are different and therefore so would be the solution. Hence, I am posting system information asked in those threads in the hope that someone could help get sound on my laptop.

  1. speaker-test -c2 -l5 -twav does produce any sound.

  2. Output of /usr/sbin/

  3. rpm -qa | grep alsa:

  4. rpm -qa | grep pulse

  5. rpm -q libasound2

  6. uname -a
    Linux linux-89nj #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux

  7. cat /etc/modprobe.d/sound
    options snd slots=snd-hda-intel

u1Nb.sgM5+Zagk53:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

Thanks in advance,

Thanks, I note a 32-bit openSUSE-11.1 with a kernel with alsa-1.0.17/1.0.18 on your HP DV4 which has a IDT 92HD71B7X hardware audio codec.

I note your mixer settings:

!!Amixer output
!!-------Mixer controls for card 0 [Intel]

Card hw:0 ‘Intel’/‘HDA Intel at 0xdc500000 irq 22’
Mixer name : ‘Generic 8086 ID 2802’
Simple mixer control ‘Master’,0
Mono: Playback 127 [100%] [0.00dB] [on]
Simple mixer control ‘Headphone’,0
Front Left: Playback 88 [69%] -29.25dB] [on]
Front Right: Playback 88 [69%] -29.25dB] [on]
Simple mixer control ‘PCM’,0
Front Left: Playback 0 [0%] -51.00dB]
Front Right: Playback 0 [0%] -51.00dB]Your PC’s PCM settings are set incorrectly. Move those up to 95% (you can back off once you have sound established).

Still, I believe you need to do more than that. My experience with HP DV4 users whose PC has the IDT 92HD71B7X hardware audio codec, is they need to edit the PC’s /etc/modprobe.d/sound file (add one line at the start), so that it looks like:

options snd-hda-intel model=hp-m4 enable_msi=1
options snd slots=snd-hda-intel
# u1Nb.sgM5+Zagk53:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

Then restart the PC and test the sound. Ensure the mixer settings did not revert back to zero during the restart.

If that does not work, we may need to update alsa from 1.0.17/1.0.18 to 1.0.21 where the commands for doing that are here (note you MUST send six zypper commands): Alsa-update - openSUSE followed by a reboot

If you do decide to update alsa to 1.0.21, in addition to updating alsa, alsa-docs and libasound2, also update alsa-utils, alsa-plugins, alsa-plugins-pulse, and alsa-oss.

Note also, the alsa-driver-kmp-pae that you install will need be specific to the kernel you have installed, and if you update to the kernel as part of an openSUSE update, you will also likely have to update (again) the alsa version to match that kernel. This is because alsa can hook right to specific bits/addresses in the new kernel which will be different from the older (thats a very very very loose way of describing this).