problem with installing sublime

Haii guys,

i tries installing opensuse 13.1 using a youtube video

i did do the way they said

  1. i unzipped the sublime zip file
    2)i moved the content to /opt
    3)i created a link and cut and pasted it into the /usr/bin folder

but when i tried to run sublime by typing in sublime in my terminal i got the following error;

sublime: error while loading shared libraries: cannot open shared object file: No such file or directory

can somebody help on this.

This is how you do it (remove/delete what you’ve done)

  1. Download your preferred version of sublime. The following link points to the current version of Sublime 3 which is in Beta, so after today it’s anyone’s guess whether the link would still be latest. But, if you don’t want to look up the most recent Sublime 3, you can still use the following to install a version which when run will then notify you and provide an automatic link to the latest (it’s just another download!) The following should work with any other version of Sublime (including Sublime 2), just insert and replace the apppropriate download file (or d/l using a web browser)

Extract the file

tar vxjf sublime *tab to complete* 

Move the file to the /opt/ directory. Instead of using sudo, I’d recommend saving some effort and just su to a root console for this and the following operation

mv sublime_text_3 /opt/

Now, go ahead and test running sublime in its new location before you create your symbolic link, while still in your root console


Sublime should launch fine, and as I described if the download wasn’t the latest you will be prompted to download a more recent build.
Now that you have a working sublime, create a symbolic link to a location already in your PATH so you can launch without a lot of typing
Again, still in your root console

ln -s /opt/sublime_text_3/sublime_text /usr/bin/sublime

Now you can launch from any console (even an ordinary non-root console).

If you want to take this further and create a Desktop menu item, that would depend on the Desktop you’re using.


I see that an artifact got inserted into the step testing sublime. Should read

Now, go ahead and test running sublime in its new location before you create your symbolic link, while still in your root console



still i can’t make it to run.

It shows the same error of that shared library…

did you try installing libgobject-2_0-0

sudo zypper in libgobject-2_0-0

IMO it’s better to install external precompiled apps that don’t come in an rpm in /usr/local/
/opt is used by some rpm packages
get sublime



tar vxjf "Sublime Text 2.0.2 x64.tar.bz2"

move to /usr/local/share

 sudo mv "Sublime Text 2" /usr/local/share

link to path

sudo ln -s "/usr/local/share/Sublime Text 2/sublime_text" /usr/local/bin/sublime

note the sublime people like using space in the dir name to use command line tools use " around path names that have spaces “Sublime Text 2”

The whole idea of shared libraries is something very old, deprecated years ago.
So, the first thing I’d really want you to verify is that you’re running a supported version of openSUSE.
If your system is ancient and you don’t want to upgrade, IIRC (and only so, because try googling “shared library path” and you won’t even get any good hits) you have to set a path for something like


And I can’t even remember for sure if that’s correct. You can also google “LD_SHARED_LIBRARY” but won’t get much of a result doing that, too. But, if my recollection is correct, then you should be able to set the above as a PATH the same way you’d set the ordinary PATH.

Otherwise, on a modern system you shouldn’t have any issue. You could install locate and verify the supposedly missing file exists on your system even if it’s not found by sublime. But, nowadays, there is no distinction between a “shared library” and any other library file so if it exists it should be found without a problem.