Problem with installing php5-imagick

Hello All!

I have OpenSuse 13.1 32 bit and PHP 5.6.9 from http://download.opensuse.org/repositories/server:/php/openSUSE_13.1/

I try to install PHP extension php5-imagick-3.3.0-2.2.i586.rpm from http://download.opensuse.org/repositories/server:/php:/extensions/openSUSE_13.1/ but get error:

Problem: php5-imagick-3.3.0-2.2.i586 requires php(api) = 20100412, but this requirement cannot be provided
uninstallable providers:
php5-5.4.20-1.2.i586[openSUSE-13.1-1.10]
php5-5.4.20-1.2.i586[repo-oss]
php5-5.4.20-12.1.i586[repo-update]
php5-5.4.20-16.1.i586[repo-update]
php5-5.4.20-21.1.i586[repo-update]
php5-5.4.20-30.1.i586[repo-update]
php5-5.4.20-34.3.i586[repo-update]
php5-5.4.20-38.1.i586[repo-update]
php5-5.4.20-4.1.i586[repo-update]
php5-5.4.20-42.1.i586[repo-update]
php5-5.4.20-45.1.i586[repo-update]
php5-5.4.20-49.1.i586[repo-update]
php5-5.4.20-52.1.i586[repo-update]
php5-5.4.20-55.2.i586[repo-update]
php5-5.4.20-58.1.i586[repo-update]
php5-5.4.20-61.5.i586[repo-update]
php5-5.4.20-64.1.i586[repo-update]
php5-5.4.20-67.1.i586[repo-update]
php5-5.4.20-8.2.i586[repo-update]

and further hints to downgrade to PHP 5.4.20

How to resolve this issue?

Thanx!

As shown here http://pecl.php.net/package-info.php?package=imagick&version=3.3.0 imagick 3.3.0 requires PHP 5.4.0+ and as i understand http://download.opensuse.org/repositories/server:/php:/ contains native repositories that should be compatibile.
Any ideas?

Have you tried ignoring the requirement?
The module <might> work and the problem is simply an incorrect requirement.

TSU