Problem with installing OpenOffice


I just installed SUSE Enterprise Server 11.

Then I wanted to install OpenOffice: So I added the Repository “/repositories/” to the Software repositories. Then I searched for OpenOffice and the software installing client found it. I wanted to mark it for installation and then it gives the message that OpenOffice depends on

Fine… So I download an rpm which should install libwpd… Then I started this rpm an Yast2 did “something” but it immediatelly stoped again without prompting any message. I checked again, but libwpd is still missing.

So I wanted to compile libwpd by myself but then it gives the following error:

*** START ***
bla …
bla …
checking for LIBWPD… configure: error: Package requirements (
glib-2.0 >= 2.0.0
libgsf-1 >= 1.6.0
) were not met:

No package ‘glib-2.0’ found
No package ‘libgsf-1’ found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBWPD_CFLAGS
and LIBWPD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
*** END ***

I tried to set PKG_CONFIG_PATH, but this didn’t work either… The strange thing is, that glib is installed as a pretty new version… So why this message???

I really don’t want to go through all this dependencies and rpms and stuff… I really just want to add OpenOffice!

Who can help me? :slight_smile:


For SuSE Linux Enterprise Server you would be best using the proper SLES repos rather than the openSuSE repos.

Or add during the install from the installation media. It should exist on the media, although I admit I have not checked.
I will check now and post back.



Ok its not on the installation DVD anymore…:\

However this URL will tell you all you need to know.

Suse & OpenSuse Tips » How to install in SLES from a SuSE Linux Enterprise Desktop ISO file

Basically uses the version from the SLED 11 install DVD.


OK, I’ll try it with the SLED-iso

→ So there is no OpenOffice repo for SLEL???

I really wonder if the problem with libwpd will dissapear with the iso …?!


> I just installed SUSE Enterprise Server 11.
> Then I wanted to install OpenOffice: So I added the Repository

my understanding is running Novell’s SLES you cannot (successfully)
use the openSUSE repos…

your options are to purchase the support agreement (giving access to
the repos) or install openSUSE…[actually, i’ve never installed SLED
or SLES so it may be that you get some days of free access to the
Novell repos…i do not know…]

if you decide to install openSUSE and want a SLES like experience you
should select the bottom option “Minimal Server Selection (Text Mode)”
when you get to this step:

HOWEVER!! OpenOffice is a GUI application and therefore will NOT run
on SLES or any other proper Linux server (since it will be a command
line only server)

if you want an enterprise desktop, buy SLED…if you want a
enterprise SERVER buy SLES…if you want both on one machine you must
be kidding, right? but, you can have both with openSUSE, free…but
you have to put up with the less than enterprise level stability…


It worked to install it with SLED CD 1… even if it is not meant to do like this… :wink:

I responded in the SLES forum to your post on what to use (The SDK as it
will be supported). Using the repositories is not supported, in that
your own your own if you have issues with the installed application.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 10 days 21:55, 3 users, load average: 0.09, 0.19, 0.25
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18